summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cbflib/cbflib-0.9.2.10-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cbflib/cbflib-0.9.2.10-r1.ebuild')
-rw-r--r--sci-libs/cbflib/cbflib-0.9.2.10-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sci-libs/cbflib/cbflib-0.9.2.10-r1.ebuild b/sci-libs/cbflib/cbflib-0.9.2.10-r1.ebuild
new file mode 100644
index 000000000000..165e6324e889
--- /dev/null
+++ b/sci-libs/cbflib/cbflib-0.9.2.10-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic fortran-2 toolchain-funcs
+
+MY_P1="CBFlib-${PV}"
+#MY_P2="CBFlib_${PV}"
+MY_P2="CBFlib_0.9.3"
+
+DESCRIPTION="Library providing a simple mechanism for accessing CBF files and imgCIF files"
+HOMEPAGE="http://www.bernstein-plus-sons.com/software/CBF/"
+BASE_TEST_URI="http://arcib.dowling.edu/software/CBFlib/downloads/version_${PV}/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P1}.tar.gz"
+# test? (
+# mirror://sourceforge/${PN}/${MY_P2}_Data_Files_Input.tar.gz
+# mirror://sourceforge/${PN}/${MY_P2}_Data_Files_Output.tar.gz
+# )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+S=${WORKDIR}/${MY_P1}
+
+RDEPEND="sci-libs/hdf5:="
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_prepare(){
+ rm -rf Py* drel* dRel* ply*
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ cp Makefile_LINUX_gcc42 Makefile
+
+ append-fflags -fno-range-check
+ append-cflags -D_USE_XOPEN_EXTENDED -DCBF_DONT_USE_LONG_LONG
+
+ sed \
+ -e "s|^SOLDFLAGS.*$|SOLDFLAGS = -shared ${LDFLAGS}|g" \
+ -i Makefile || die
+ tc-export CC CXX AR RANLIB
+}
+
+src_compile() {
+ emake -j1 shared
+}
+
+src_test(){
+ emake -j1 basic
+}
+
+src_install() {
+ insinto /usr/include/${PN}
+ dosym ${PN} /usr/include/cbf
+ doins include/*.h
+
+ dolib.so solib/lib*
+
+ dodoc README
+ use doc && dohtml -r README.html html_graphics doc
+}