summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-07-02 00:22:08 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-07-02 13:03:44 +0200
commite4f62deb1b127d32fc9845d5e90d21a0c090bf53 (patch)
tree276987ab38b0be5676f76169d360d1ef6fa53c46 /sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch
parentdev-qt/qtxmlpatterns: Stabilize 5.15.5 ppc64, #853232 (diff)
downloadgentoo-e4f62deb1b127d32fc9845d5e90d21a0c090bf53.tar.gz
gentoo-e4f62deb1b127d32fc9845d5e90d21a0c090bf53.tar.bz2
gentoo-e4f62deb1b127d32fc9845d5e90d21a0c090bf53.zip
sci-libs/caffe2: add XNNPACK usage
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch')
-rw-r--r--sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch b/sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch
index ac74edadab35..f34216ea0970 100644
--- a/sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch
+++ b/sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch
@@ -91,3 +91,22 @@
install(DIRECTORY ${CMAKE_CURRENT_LIST_DIR}
DESTINATION include
FILES_MATCHING PATTERN "*.h")
+--- a/caffe2/CMakeLists.txt 2022-07-01 21:56:49.643490049 +0200
++++ b/caffe2/CMakeLists.txt 2022-07-01 21:57:17.091489479 +0200
+@@ -109,7 +109,7 @@
+ # Note: the folders that are being commented out have not been properly
+ # addressed yet.
+
+-if(NOT MSVC AND USE_XNNPACK)
++if(FALSE)
+ if(NOT TARGET fxdiv)
+ set(FXDIV_BUILD_TESTS OFF CACHE BOOL "")
+ set(FXDIV_BUILD_BENCHMARKS OFF CACHE BOOL "")
+@@ -967,7 +967,6 @@
+ endif()
+
+ if(NOT MSVC AND USE_XNNPACK)
+- TARGET_LINK_LIBRARIES(torch_cpu PRIVATE fxdiv)
+ endif()
+
+ # ==========================================================