summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2023-10-28 00:24:59 -0700
committerYixun Lan <dlan@gentoo.org>2023-10-28 14:21:50 +0000
commit398dc31c1a650c0815a87332a7ec3bd87822562f (patch)
tree21ec7a940e0ef15666100ddab227ede5d8760f7a /sci-electronics
parentsci-electronics/kicad: add 7.0.8 (diff)
downloadgentoo-398dc31c1a650c0815a87332a7ec3bd87822562f.tar.gz
gentoo-398dc31c1a650c0815a87332a7ec3bd87822562f.tar.bz2
gentoo-398dc31c1a650c0815a87332a7ec3bd87822562f.zip
sci-electronics/kicad-footprints: add 7.0.8
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad-footprints/Manifest1
-rw-r--r--sci-electronics/kicad-footprints/kicad-footprints-7.0.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-electronics/kicad-footprints/Manifest b/sci-electronics/kicad-footprints/Manifest
index 234c930dee4a..924daeb2d456 100644
--- a/sci-electronics/kicad-footprints/Manifest
+++ b/sci-electronics/kicad-footprints/Manifest
@@ -1,2 +1,3 @@
DIST kicad-footprints-7.0.1.tar.bz2 23942389 BLAKE2B 06408aaf1a388287dc0929f8f99e70bcab62051da1a4674f48ea264a75fd5780fe355420dafe96fd8548679c508a3860bdc0ba8ef287a3c7b3c6c78c0fdc2975 SHA512 1bc7ffdf089414c40e74a2b8c155e83900d406f46036d0803f115e505e25f7071111acc5bc85456de4c96af26d8a13ca81bd28dca5dfe48e26e5944f4478a688
DIST kicad-footprints-7.0.7.tar.bz2 24411508 BLAKE2B 1abedfbc3dfab302b5f929b01f2a83e83a4fee6b1d5056bf2c3579068c56807c656dea918f4c37fe030b727d3effbc35063f4f4103c4cfa6071f95c22d507597 SHA512 8af1fb371034bd5b22e0a8a896fa61e4eb0bda5b282759e17872bf4b466f49b39aa56ae068ac3d7d5a7453d9a7d511a81317d3f267a90d2764b2b8282f64aef0
+DIST kicad-footprints-7.0.8.tar.bz2 24418267 BLAKE2B d252a75adafbb8ccbe000ad290e1a0ec6044c5662a899812de3466e2fe23d8f3833b54b9c17863ddf26a1e032af404daacdb7848a9517313943b43d1b9ed488e SHA512 984cff22967dd82ec1e4706a61c68bf2357f391c4efccd80dadcae18f71ff0a90fdc61a54b491440da2a2dc7f1a2fc03091e01c9791a919db7a31920ec5b7b02
diff --git a/sci-electronics/kicad-footprints/kicad-footprints-7.0.8.ebuild b/sci-electronics/kicad-footprints/kicad-footprints-7.0.8.ebuild
new file mode 100644
index 000000000000..ba02cb94ca78
--- /dev/null
+++ b/sci-electronics/kicad-footprints/kicad-footprints-7.0.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools footprint libraries"
+HOMEPAGE="https://gitlab.com/kicad/libraries/kicad-footprints"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/kicad-footprints.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sci-electronics/kicad-7.0.0"
+
+if [[ ${PV} == 9999 ]] ; then
+# x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi