summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-05 19:43:41 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-05 19:48:55 +0200
commit99f627b10224a2cb3029cd49f42d7d0138e2320c (patch)
treecc36f3b70ddc94120ecae9d974b21e17a62b46ce /sci-electronics/gspiceui
parentsci-chemistry/wxmacmolplt: drop 7.5-r1 (diff)
downloadgentoo-99f627b10224a2cb3029cd49f42d7d0138e2320c.tar.gz
gentoo-99f627b10224a2cb3029cd49f42d7d0138e2320c.tar.bz2
gentoo-99f627b10224a2cb3029cd49f42d7d0138e2320c.zip
sci-electronics/gspiceui: add 1.3.30_pre20240321
Closes: https://bugs.gentoo.org/918633 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-electronics/gspiceui')
-rw-r--r--sci-electronics/gspiceui/Manifest1
-rw-r--r--sci-electronics/gspiceui/files/gspiceui-1.3.30_pre20240321-respect-users-flags.patch50
-rw-r--r--sci-electronics/gspiceui/gspiceui-1.3.30_pre20240321.ebuild78
3 files changed, 129 insertions, 0 deletions
diff --git a/sci-electronics/gspiceui/Manifest b/sci-electronics/gspiceui/Manifest
index 8e067dce86db..226356f48245 100644
--- a/sci-electronics/gspiceui/Manifest
+++ b/sci-electronics/gspiceui/Manifest
@@ -1,2 +1,3 @@
+DIST gspiceui-1.3.30_pre20240321.zip 80103549 BLAKE2B 5cdbd2338dd057d73a01572e75a7af145bca99f3e9339d259ae3615076e26a5c1614eecdd1e32cd669ecdd2a5cc1e3934dc3d3f1b36980c7a2eed7c6c15e1bb6 SHA512 736f7eafbaa26c3d9b3fa0df1ae5071adf21c0716519a99a0b9d199aa10a0dd402273de51d2e16b07be4c145ab2d34e133c515a8cfbb44068aa46cdc36a20658
DIST gspiceui-v1.1.00.tar.gz 1048236 BLAKE2B cc3d14137517cd26687dabac7e001e7518fee91aedc74f1995ac763873345f2965c3edb4e037ecb6ac8ca874289b2e658fe3185d95b3eeaf2b349efab151f37b SHA512 46ccf3dd7a5dd9ec1cac1eb742187ecab15a6c0033467d52a44c916e239696faf7b8797e1a155191cf0ed37b04619b0666cff51e78912a06ecd2c63d377cba93
DIST gspiceui-v1.2.87.tar.gz 1089733 BLAKE2B c1801bfebd5d42fe9c1ab26e6fd0cb06b56cac53bbad272522896325e5fd979e6fcc63d6f99262b152180f249b5b2d4aa119aa83254a2fc07256574c9ebaef10 SHA512 081d04c39f4fb96139f12fa063dfb888e036948a00a6b55de3b04a49b2b4af01b45fd9b7f903855d798a71957452550dfa8c8505c167c239e27ada29cb6fa747
diff --git a/sci-electronics/gspiceui/files/gspiceui-1.3.30_pre20240321-respect-users-flags.patch b/sci-electronics/gspiceui/files/gspiceui-1.3.30_pre20240321-respect-users-flags.patch
new file mode 100644
index 000000000000..531491829bd3
--- /dev/null
+++ b/sci-electronics/gspiceui/files/gspiceui-1.3.30_pre20240321-respect-users-flags.patch
@@ -0,0 +1,50 @@
+--- a/src/Makefile.old 2024-06-21 11:25:45.990728109 +0200
++++ b/src/Makefile 2024-06-21 11:33:20.289571247 +0200
+@@ -46,8 +46,8 @@
+ #***************************************************************************************************
+
+ # Which compiler and linker (eg. g++ or clang++)
+-CXX = g++
+-LD = g++
++CXX ?= g++
++LD ?= g++
+ ifneq ($(GSPICEUI_MSWIN),0)
+ LD += -static-libstdc++ -static-libgcc
+ WINDRES = windres
+@@ -108,17 +108,7 @@
+ # -fabi-version=N Use version N of the C++ ABI (this choice must match the wxWidgets library)
+
+ CXXFLAGS := -std=c++17 -fabi-version=14
+-ifeq ($(GSPICEUI_DEBUG),0)
+- # Options for release (not using -Wall since it's GCC specific)
+- CXXFLAGS += -O3
+-else
+- # Options for development
+- CXXFLAGS += -g3 -O0 -Wall -Wextra -Wpedantic
+-
+- # The following warning has been disabled because I don't know how to fix it
+- CXXFLAGS += -Wno-overloaded-virtual
+-endif
+-CXXFLAGS += -pipe $(shell $(WXCFG) --cxxflags)
++CXXFLAGS += $(shell $(WXCFG) --cxxflags)
+
+ # I like to compile using the option "-Wall" etc. however tests that break wxWidgets are turned off
+ ifneq ($(GSPICEUI_DEBUG),0)
+@@ -231,7 +221,7 @@
+ # -o specify the output file name
+
+ $(BINDIR)/$(PROG) : $(OBJS)
+- $(LD) -pipe -o $(BINDIR)/$(PROG) obj/*.o $(LIBS)
++ $(CXX) -o $(BINDIR)/$(PROG) obj/*.o $(LDFLAGS) $(LIBS)
+ ifeq ($(ROOT)/GSpiceUI.app,$(wildcard $(ROOT)/GSpiceUI.app))
+ cp $(BINDIR)/$(PROG) $(ROOT)/GSpiceUI.app/Contents/MacOS/gspiceui
+ endif
+@@ -296,7 +286,7 @@
+
+ # Compiler options
+
+-test_% : CXXFLAGS = -Wall -g -pipe $(shell $(WXCFG) --cxxflags)
++test_% : CXXFLAGS += $(shell $(WXCFG) --cxxflags)
+ test_% : CXXFLAGS += -D $(shell echo $@ | tr "[:lower:]" "[:upper:]")
+ # Libraries
+ test_% : LIBS = $(shell $(WXCFG) --libs core,base)
diff --git a/sci-electronics/gspiceui/gspiceui-1.3.30_pre20240321.ebuild b/sci-electronics/gspiceui/gspiceui-1.3.30_pre20240321.ebuild
new file mode 100644
index 000000000000..afbe20c26ef0
--- /dev/null
+++ b/sci-electronics/gspiceui/gspiceui-1.3.30_pre20240321.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit desktop optfeature wxwidgets xdg
+
+DESCRIPTION="GUI frontend for Ngspice and Gnucap"
+HOMEPAGE="https://sourceforge.net/projects/gspiceui/"
+#SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.tar.gz"
+MY_REV="382"
+# SF source is temporal
+#SRC_URI="https://sourceforge.net/code-snapshots/svn/g/gs/${PN}/code/${PN}-code-r${MY_REV}-trunk.zip -> ${P}.zip"
+SRC_URI="https://dev.gentoo.org/~pacho/${PN}/${PN}-code-r${MY_REV}-trunk.zip -> ${P}.zip"
+S="${WORKDIR}/${PN}-code-r${MY_REV}-trunk"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ sci-electronics/electronics-menu
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ sci-electronics/ngspice
+ sci-electronics/gnucap
+ )
+"
+
+PATCHES=(
+ # Use Gentoo LDFLAGS and CXXFLAGS
+ # https://sourceforge.net/p/gspiceui/bugs/30/
+ "${FILESDIR}"/${P}-respect-users-flags.patch
+)
+
+src_configure() {
+ setup-wxwidgets
+ default
+}
+
+src_compile() {
+ export HOME="${T}"
+ mkdir -p "${T}/.config"
+ emake GSPICEUI_WXLIB=3.2 GSPICEUI_DEBUG=0
+}
+
+src_install() {
+ dobin bin/gspiceui
+
+ einstalldocs
+ dodoc html/*.html html/*.jpg html/*.png
+ dodoc ChangeLog ReadMe ToDo
+ doman gspiceui.1
+
+ # installing examples and according model and symbol files
+ use examples && dodoc -r lib sch
+
+ newicon -s 32 src/icons/gspiceui-32x32.xpm gspiceui.xpm
+ newicon -s 48 src/icons/gspiceui-48x48.xpm gspiceui.xpm
+ make_desktop_entry gspiceui "GNU Spice GUI" gspiceui "Electronics"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if use examples ; then
+ elog "If you want to use the examples, copy and extract from"
+ elog "${EROOT}/usr/share/doc/${PF} the sch and lib directory"
+ elog "side by side to your home directory to be able"
+ elog "to generate the netlists as normal user."
+ fi
+ optfeature "schematics editing" sci-electronics/geda
+ optfeature "waveform display" sci-electronics/gwave
+}