summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-11-08 20:35:55 +0100
committerPacho Ramos <pacho@gentoo.org>2024-11-08 20:44:29 +0100
commit6affc1f9f7e8ab1c07f727eb96e1b1e3de0f3a81 (patch)
tree43a6337daae1d70c674920424d75593cd81478bf /sci-chemistry/chemex
parentgames-arcade/methane: add 2.1.0 (diff)
downloadgentoo-6affc1f9f7e8ab1c07f727eb96e1b1e3de0f3a81.tar.gz
gentoo-6affc1f9f7e8ab1c07f727eb96e1b1e3de0f3a81.tar.bz2
gentoo-6affc1f9f7e8ab1c07f727eb96e1b1e3de0f3a81.zip
sci-chemistry/chemex: add 2024.09.25
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry/chemex')
-rw-r--r--sci-chemistry/chemex/Manifest1
-rw-r--r--sci-chemistry/chemex/chemex-2024.09.25.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/Manifest b/sci-chemistry/chemex/Manifest
index a78be349b4e6..2d67eb0e0590 100644
--- a/sci-chemistry/chemex/Manifest
+++ b/sci-chemistry/chemex/Manifest
@@ -1,2 +1,3 @@
DIST chemex-2024.05.2.tar.gz 2757082 BLAKE2B e231f2b4da566b633cdd10c54f413b319847e86ab909b81ca78e0cf5c368f4cd039fc26d4214f464de1ca618ea5bbd8579e9bfeaa4a97e01ef3ddecb1d8c8227 SHA512 29e137a1d275f5c6b078081350b8d9a6f9172858adb744afdbbdbbe94dc9953f1fb37ad49e10f2d39db89e90c2c8d5b17a53ec9be337772bb531052ae4ab86f1
DIST chemex-2024.05.3.tar.gz 2757407 BLAKE2B 8f98cda5158224bf06b4e81271157b7d6dd6c28526a6fd0362090d51d2fb2402a5dffc422862f129ffe7db22ec87ee49a12a1bd1a812e88014d4b1956e626ff7 SHA512 f2a29c03d9375b440206e1cd08d0f656ec6f9c627b15645663ee0d249731adb9619fa2ad5792e55e7219e11165d20a7d25b00ee9766daf580490cb4c8ea77ebf
+DIST chemex-2024.09.25.tar.gz 2759061 BLAKE2B 28f39595db36476d30122ff4b7a163e6e09205a98c7bcb777503963a5790831eb40ffcc8363c5ff94cf6fc12cb88cf289fa295ffcf6c7bca6564e2b9e1654b4a SHA512 bbfce1903ebbd797001a1c526ffb20da08c33f8d142c3912711cdc87aa04a3044b0b176841223fbb341e1e90c9a28fa2c13716b4ac502753839fa310028be625
diff --git a/sci-chemistry/chemex/chemex-2024.09.25.ebuild b/sci-chemistry/chemex/chemex-2024.09.25.ebuild
new file mode 100644
index 000000000000..87646d2c3045
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2024.09.25.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/annotated-types-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-5.3.3[${PYTHON_USEDEP}]
+ >=dev-python/emcee-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.8.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.26.4[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.13.0[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}