summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-19 20:04:32 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-19 20:04:32 +0200
commita37fac276f1cf3c146ed34d706cf8f056950a8e1 (patch)
treedd2595d3415f0b429a500022ef3bbcb977902130 /sci-biology/prints/prints-39.0-r2.ebuild
parentsci-biology/rebase: update EAPI 6 -> 8 (diff)
downloadgentoo-a37fac276f1cf3c146ed34d706cf8f056950a8e1.tar.gz
gentoo-a37fac276f1cf3c146ed34d706cf8f056950a8e1.tar.bz2
gentoo-a37fac276f1cf3c146ed34d706cf8f056950a8e1.zip
sci-biology/prints: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/prints/prints-39.0-r2.ebuild')
-rw-r--r--sci-biology/prints/prints-39.0-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/prints/prints-39.0-r2.ebuild b/sci-biology/prints/prints-39.0-r2.ebuild
new file mode 100644
index 000000000000..9fb721842798
--- /dev/null
+++ b/sci-biology/prints/prints-39.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/./_}"
+
+DESCRIPTION="A protein motif fingerprint database"
+HOMEPAGE="http://www.bioinf.man.ac.uk/dbbrowser/PRINTS/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emboss minimal"
+
+BDEPEND="emboss? ( sci-biology/emboss )"
+RDEPEND="${BDEPEND}"
+
+src_compile() {
+ if use emboss; then
+ mkdir PRINTS || die
+ einfo
+ einfo "Indexing PRINTS for usage with EMBOSS"
+ EMBOSS_DATA="." printsextract -auto -infile prints${MY_PV}.dat || die "Indexing PRINTS failed"
+ einfo
+ fi
+}
+
+src_install() {
+ dodoc README
+
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins newpr.lis ${PN}${MY_PV}.{all.fasta,dat,kdat,lis,nam,vsn}
+ fi
+
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/${PN^^}
+ doins -r ${PN^^}/.
+ fi
+}