summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-09-06 01:31:47 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-09-06 11:29:55 +0300
commita0f8d0cf907d73eb5d35dde1025b3562386c20f2 (patch)
tree5cf02f20196676207fb7b1b91973d5bf56988867 /sci-astronomy
parentsys-auth/sssd: add 2.9.1 (diff)
downloadgentoo-a0f8d0cf907d73eb5d35dde1025b3562386c20f2.tar.gz
gentoo-a0f8d0cf907d73eb5d35dde1025b3562386c20f2.tar.bz2
gentoo-a0f8d0cf907d73eb5d35dde1025b3562386c20f2.zip
sci-astronomy/stellarium: use indilib 1.8.5
I'm not restoring older sci-libs/indilib because depending on it would prevent installing latest indilib at the same time, and actually 1.9.8 doesn't build anymore without patching While Stellarium supports using external indilib, it also has support for downloading version 1.8.5 inside cmake using CPM, and using the needed parts of it statically - that's how official packages are built; here I'm telling CPM to not download it automatically, but use the source downloaded by portage Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Bug: https://bugs.gentoo.org/913177 Closes: https://github.com/gentoo/gentoo/pull/32641 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stellarium/Manifest1
-rw-r--r--sci-astronomy/stellarium/stellarium-23.2-r1.ebuild (renamed from sci-astronomy/stellarium/stellarium-23.2.ebuild)11
2 files changed, 10 insertions, 2 deletions
diff --git a/sci-astronomy/stellarium/Manifest b/sci-astronomy/stellarium/Manifest
index ec5ff3c6f920..7c6a5509eaab 100644
--- a/sci-astronomy/stellarium/Manifest
+++ b/sci-astronomy/stellarium/Manifest
@@ -1,3 +1,4 @@
+DIST indilib-1.8.5.tar.gz 2122866 BLAKE2B 203b6c78664aaf3f87b7f697b76544e6ed0fa6db8ac0fe43e6ebcf00de404e96a49b8cd7f8b0be2e4ff5c7f902b3e34177a244a4a49069887f11d28aea073620 SHA512 4c583f7ff0d96d787c7d035e23074f42db3f836ec74a0a7a1595574ae2d32d56234b16abddabacaf9bd5a10cb88c6c37994aafcef86d65a665b2bceae87446f9
DIST stars_4_1v0_2.cat 16948302 BLAKE2B 6efe02c6343fa3cd121879dddd3017dbd42a7c8965481b1ab79a258cedc4adc85df25240003b95c325eb35a8ed9686c38b2590f78aff9cd400ecac675583232d SHA512 80e5b2d0bc78c09658e84e7ee57309be290ba66a131ff38aa471235ff513d7824b28f6852ba1fdb485f86ede1fb2388cfb6327b2f1fe60bb097ce0cdbe48d2cb
DIST stars_5_2v0_1.cat 42580300 BLAKE2B eb6528c0577b3f2001a8b03cc5a4e08fa4e75723f677d0dda98d27c50791d9825c0e0feca7b00f0cb82ce362bc83f3e8dc2260d14e81e4a070cbbfa44f2107ba SHA512 6fc0f7352d1165a0744cc932b6d379741e4614d5a95edd136522c789eaa8d1bcf05d7445f7dfd6896e8183aa64bf37b3610d87902b54542f62f2418b285892e0
DIST stars_6_2v0_1.cat 148352404 BLAKE2B c605b284b3d768cb1619ada3f58d406fa7737f09949e8926d6c14b82a85927d124d7fcb50c6d6c357d21b003938cc0b28937f2adb28ae268bb5c85d575f5e0ff SHA512 794279407595f44bbc1e492086063d98068bf332202a5448cd83dd7afbdcf7c6c3ff2878f3016369ebb5a98552874eb4eddb38e2c40e9a163c6231b640e02977
diff --git a/sci-astronomy/stellarium/stellarium-23.2.ebuild b/sci-astronomy/stellarium/stellarium-23.2-r1.ebuild
index 4c2406c674bd..76d6e6f498a1 100644
--- a/sci-astronomy/stellarium/stellarium-23.2.ebuild
+++ b/sci-astronomy/stellarium/stellarium-23.2-r1.ebuild
@@ -26,11 +26,14 @@ SRC_URI="
https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_6_2v0_1.cat
https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_7_2v0_1.cat
https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_8_2v0_1.cat
+ )
+ telescope? (
+ https://github.com/indilib/indi/archive/v1.8.5.tar.gz -> indilib-1.8.5.tar.gz
)"
LICENSE="GPL-2+ SGI-B-2.0"
SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
IUSE="debug deep-sky doc gps media nls qt6 +scripting +show-my-sky stars telescope test webengine +xlsx"
# Python interpreter is used while building RemoteControl plugin
@@ -85,7 +88,6 @@ RDEPEND="
webengine? ( dev-qt/qtwebengine:6[widgets] )
xlsx? ( dev-libs/qxlsx:=[qt6] )
)
- telescope? ( sci-libs/indilib:= )
"
DEPEND="${RDEPEND}
!qt6? (
@@ -149,6 +151,11 @@ src_configure() {
-DUSE_PLUGIN_TELESCOPECONTROL="$(usex telescope)"
"$(cmake_use_find_package doc Doxygen)"
)
+ if use telescope; then
+ mycmakeargs+=(
+ -DCPM_indiclient_SOURCE="${WORKDIR}/indi-1.8.5"
+ )
+ fi
cmake_src_configure
}