summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-10-20 10:55:02 +0200
committerPacho Ramos <pacho@gentoo.org>2019-10-20 10:55:47 +0200
commit2db8345584f1f074d4e823ce52d04bb1dd39a931 (patch)
treec6d29ce26ce4d47bf53b0bbebacc00c0e0481d14 /net-wireless
parentnet-libs/libpcap: arm stable wrt bug #696040 (diff)
downloadgentoo-2db8345584f1f074d4e823ce52d04bb1dd39a931.tar.gz
gentoo-2db8345584f1f074d4e823ce52d04bb1dd39a931.tar.bz2
gentoo-2db8345584f1f074d4e823ce52d04bb1dd39a931.zip
net-wireless/bluez: Fix building in non-glibc systems
Thanks-to: Jory A. Pratt Closes: https://bugs.gentoo.org/695940 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez/bluez-5.51.ebuild5
-rw-r--r--net-wireless/bluez/files/bluez-5.51-include-limits-h.patch64
2 files changed, 69 insertions, 0 deletions
diff --git a/net-wireless/bluez/bluez-5.51.ebuild b/net-wireless/bluez/bluez-5.51.ebuild
index 00a51cb60471..792792341b4f 100644
--- a/net-wireless/bluez/bluez-5.51.ebuild
+++ b/net-wireless/bluez/bluez-5.51.ebuild
@@ -69,6 +69,11 @@ PATCHES=(
# http://article.gmane.org/gmane.linux.bluez.kernel/67230
"${FILESDIR}"/${PN}-5.39-systemd-quote.patch
+ # Include limits.h for PATH_MAX
+ # https://marc.info/?l=linux-bluetooth&m=157156119320950&w=2
+ # https://bugs.gentoo.org/695940
+ "${FILESDIR}"/${PN}-5.51-include-limits-h.patch
+
# Fedora patches
# http://www.spinics.net/lists/linux-bluetooth/msg40136.html
"${FILESDIR}"/0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
diff --git a/net-wireless/bluez/files/bluez-5.51-include-limits-h.patch b/net-wireless/bluez/files/bluez-5.51-include-limits-h.patch
new file mode 100644
index 000000000000..ccbc152a4ee1
--- /dev/null
+++ b/net-wireless/bluez/files/bluez-5.51-include-limits-h.patch
@@ -0,0 +1,64 @@
+From 20128c5c95fbae93c9fd996d5ad2584cf6ad8032 Mon Sep 17 00:00:00 2001
+From: Jory Pratt <anarchy@gentoo.org>
+Date: Mon, 30 Sep 2019 18:35:56 -0500
+Subject: [PATCH] Include limits.h for PATH_MAX
+
+Signed-off-by: Jory Pratt <anarchy@gentoo.org>
+---
+ mesh/keyring.c | 1 +
+ mesh/mesh-config-json.c | 1 +
+ mesh/node.c | 1 +
+ mesh/util.c | 1 +
+ 4 files changed, 4 insertions(+)
+
+diff --git a/mesh/keyring.c b/mesh/keyring.c
+index 3a7f92f..9fa7d6b 100644
+--- a/mesh/keyring.c
++++ b/mesh/keyring.c
+@@ -24,6 +24,7 @@
+ #define _GNU_SOURCE
+ #include <fcntl.h>
+ #include <dirent.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <dirent.h>
+diff --git a/mesh/mesh-config-json.c b/mesh/mesh-config-json.c
+index cafa2fd..74ca495 100644
+--- a/mesh/mesh-config-json.c
++++ b/mesh/mesh-config-json.c
+@@ -27,6 +27,7 @@
+ #include <fcntl.h>
+ #include <ftw.h>
+ #include <libgen.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+diff --git a/mesh/node.c b/mesh/node.c
+index b6824f5..15dcb97 100644
+--- a/mesh/node.c
++++ b/mesh/node.c
+@@ -23,6 +23,7 @@
+
+ #define _GNU_SOURCE
+ #include <dirent.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <sys/time.h>
+
+diff --git a/mesh/util.c b/mesh/util.c
+index 1455bde..986ba4b 100644
+--- a/mesh/util.c
++++ b/mesh/util.c
+@@ -25,6 +25,7 @@
+ #include <dirent.h>
+ #include <ftw.h>
+ #include <stdio.h>
++#include <limits.h>
+ #include <time.h>
+ #include <sys/time.h>
+
+--
+2.23.0
+