summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetru Ciobanu <scantlight@gmail.com>2023-04-30 19:52:17 -0700
committerJoonas Niilola <juippis@gentoo.org>2023-05-18 10:51:00 +0300
commit83203f70b05e5af1ab51414bf61a4fad17a7e82e (patch)
tree40d14c23a232372cd5af801c0ab5bb04d9f3c982 /net-vpn
parentapp-emulation/firecracker-bin: add 1.3.2 (diff)
downloadgentoo-83203f70b05e5af1ab51414bf61a4fad17a7e82e.tar.gz
gentoo-83203f70b05e5af1ab51414bf61a4fad17a7e82e.tar.bz2
gentoo-83203f70b05e5af1ab51414bf61a4fad17a7e82e.zip
net-vpn/openfortivpn: add 1.20.2
net-dialup/ppp-2.5.0 is incompatible. A new connection fails with 'Peer refused to agree to his IP address' message. see adrienverge/openfortivpn/issues/1076 Signed-off-by: Petru Ciobanu <scantlight@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30818 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.20.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index 674cf4fbac1c..96053ddc300f 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1 +1,2 @@
DIST openfortivpn-1.19.0.tar.gz 168962 BLAKE2B f2cff6f89a0662aca5911f6c3ef5953181383d4a66a41df83916c551338f07364436a174de39874cb654d6538955ac5d0a57a875facf2cc9b8c8a27a48df7fbf SHA512 4f4179178cbf2fc03ddebdfd4197c03a7108ecfa5216d5f11d80b2e3b840816f0a9a59714f58ecdcf966b76eb9b459e0bf78901940120ed1aa1cf69021385a53
+DIST openfortivpn-1.20.2.tar.gz 167680 BLAKE2B fec9ef5f38af6cf32283cb281d0871115c3ddface35bbbe5fb96cd132cf2f586bd21ddaf55424bc902ea3984472109ec40ee4fd16706d10cc1795b4d68216b1d SHA512 e3ad8e74f7ba05f61df464af8a6ff6ba41e0c73ad52fbb9eaa9485814788a4636800b91cdd88f88caecbc9e305b2759a628b02fbe2eaf12d33c7912bb3ce065b
diff --git a/net-vpn/openfortivpn/openfortivpn-1.20.2.ebuild b/net-vpn/openfortivpn/openfortivpn-1.20.2.ebuild
new file mode 100644
index 000000000000..807cee798b75
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.20.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl:0=
+ <net-dialup/ppp-2.5.0
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+PATCHES=(
+ "${FILESDIR}/systemd_substitute_bin_and_sysconfig_dirs.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}