summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetru Ciobanu <scantlight@gmail.com>2022-10-09 13:02:45 -0700
committerJoonas Niilola <juippis@gentoo.org>2022-10-27 15:55:55 +0300
commit1f9fa59a9f30c51e3cc414e8d4d97f956dd45308 (patch)
tree92477f23a71f452367c8da50707b5e7abfdab267 /net-vpn/openfortivpn
parentmedia-video/ffdiaporama: version bump to 2.2_pre20221007 (diff)
downloadgentoo-1f9fa59a9f30c51e3cc414e8d4d97f956dd45308.tar.gz
gentoo-1f9fa59a9f30c51e3cc414e8d4d97f956dd45308.tar.bz2
gentoo-1f9fa59a9f30c51e3cc414e8d4d97f956dd45308.zip
net-vpn/openfortivpn: add 1.18.0
Signed-off-by: Petru Ciobanu <scantlight@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27710 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-vpn/openfortivpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.18.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index 9953217d977e..10982443f13e 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1 +1,2 @@
DIST openfortivpn-1.17.1.tar.gz 167127 BLAKE2B 4b8f9fb82c4f7c8ffcecf9f14c576d73c999712b7b183b74f9d60d59c67017080a3d16d95ae74fa7f07188e9b28bdf8384f9b41ea7a4ce8e24813044d27216b9 SHA512 9d8be1043833bfa0eba6e4032c767946e88d079d329f8039964ea659c4dffb54a5a3b2a6431b66bd86590eaca8bf598a110c368714ecd7ea00312ee97f329085
+DIST openfortivpn-1.18.0.tar.gz 169141 BLAKE2B 28ac333bd1aa5b7be1e8cfb5a3dd968f2852c445d86050db2eb3161a6b7cd7f765607a3c8ec8bb8c65ba7d8340d8f526f08703ab6df9ab4f7a9f2d2666d767df SHA512 77a1c102e8bd6dfe5a86fe375449a3dd0253634d555dc084bd188a97d855afdd16f71b5b25fd6b737381c7da332228e22e3519d5a2b1d49099c56bc7c21e6088
diff --git a/net-vpn/openfortivpn/openfortivpn-1.18.0.ebuild b/net-vpn/openfortivpn/openfortivpn-1.18.0.ebuild
new file mode 100644
index 000000000000..7a5b0426a114
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.18.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ net-dialup/ppp
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+PATCHES=(
+ "${FILESDIR}/systemd_substitute_bin_and_sysconfig_dirs.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}