summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-02-22 11:11:47 -0600
committerBen Kohler <bkohler@gentoo.org>2023-02-22 11:12:53 -0600
commit822e5d2252f2402c3b3b89fd924c83bb9f09f083 (patch)
treee31b690980d200baecb5df44f087fe248df7f6c5 /net-proxy/tinyproxy
parentmedia-libs/libopenraw: Stabilize 0.3.3 ppc64, #895380 (diff)
downloadgentoo-822e5d2252f2402c3b3b89fd924c83bb9f09f083.tar.gz
gentoo-822e5d2252f2402c3b3b89fd924c83bb9f09f083.tar.bz2
gentoo-822e5d2252f2402c3b3b89fd924c83bb9f09f083.zip
net-proxy/tinyproxy: new snapshot plus _FORTIFY_SOURCE fix
Closes: https://bugs.gentoo.org/895872 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-proxy/tinyproxy')
-rw-r--r--net-proxy/tinyproxy/Manifest1
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.11.1_p20230201.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-proxy/tinyproxy/Manifest b/net-proxy/tinyproxy/Manifest
index ffc77e758748..2560c805b71f 100644
--- a/net-proxy/tinyproxy/Manifest
+++ b/net-proxy/tinyproxy/Manifest
@@ -1 +1,2 @@
DIST tinyproxy-1.11.1_p20220908.tar.gz 112898 BLAKE2B 0f00a103661a5e5891a9f82cb95f1a421a47e68ea6e2144ead01241e6b4bcda8dbd4dce302432fa0432aae1e048b4a788a0ad3bad2dc8691906b872730c31b2b SHA512 3d1c0ad4915e81e775e981b8ba625664128c8d63b2093cc29b3873dc83da4e16646e2a39e32769f463bab1d5af2b699deaa546a705f1269d5a6dfc2c927dafef
+DIST tinyproxy-31339cb1615765f2fbb4ec7779400535bad6da46.tar.gz 112886 BLAKE2B 82af9f671b31c9be46624400d726e428837763ab763942c335df1aa63499e33c17384b55ea2f68790cd3b8b1e4eff3b61b40f25e1d55506ce0f0694c7cddaddb SHA512 638ae0731aa2d9f498643aa883871f7b3978c68ee5098fcbeb234234e5432d1a833c33fb0cc1944504369bdf975baa0bd6166664c340825b9b55664d8afdf94c
diff --git a/net-proxy/tinyproxy/tinyproxy-1.11.1_p20230201.ebuild b/net-proxy/tinyproxy/tinyproxy-1.11.1_p20230201.ebuild
new file mode 100644
index 000000000000..7af955c819a2
--- /dev/null
+++ b/net-proxy/tinyproxy/tinyproxy-1.11.1_p20230201.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd tmpfiles
+
+COMMIT=31339cb1615765f2fbb4ec7779400535bad6da46
+
+DESCRIPTION="A lightweight HTTP/SSL proxy"
+HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
+SRC_URI="https://github.com/tinyproxy/tinyproxy/archive/${COMMIT}.tar.gz -> ${PN}-${COMMIT}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="test debug +filter-proxy reverse-proxy transparent-proxy
++upstream-proxy +xtinyproxy-header"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( xtinyproxy-header )"
+
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+DEPEND="
+ acct-group/tinyproxy
+ acct-user/tinyproxy
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|nobody|${PN}|g" \
+ etc/${PN}.conf.in || die "sed failed"
+
+ sed -i -e "s# -Wp,-D_FORTIFY_SOURCE=2##" configure.ac || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable filter-proxy filter) \
+ $(use_enable reverse-proxy reverse) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable upstream-proxy upstream) \
+ $(use_enable xtinyproxy-header xtinyproxy) \
+ --localstatedir=/var
+}
+
+src_test() {
+ # The make check target does not run the test suite
+ emake test
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ diropts -m0775 -o ${PN} -g ${PN}
+ keepdir /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.10.0.initd tinyproxy
+ systemd_newunit "${FILESDIR}"/${PN}-1.10.0.service tinyproxy.service
+ dotmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog "For filtering domains and URLs, enable filter option in the configuration"
+ elog "file and add them to the filter file (one domain or URL per line)."
+}