summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2023-02-28 20:42:59 -0500
committerPiotr Karbowski <slashbeast@gentoo.org>2023-03-01 23:33:58 +0100
commit9149a2e696c66a4bda804fcf44c0ec6b3bf75d9a (patch)
treee574028f96a0fba3ec5dab49c485a34a0f2ebb00 /net-p2p
parentfeatures/musl/package.use.mask: mask net-analyzer/nagios-plugin-check_raid[aa... (diff)
downloadgentoo-9149a2e696c66a4bda804fcf44c0ec6b3bf75d9a.tar.gz
gentoo-9149a2e696c66a4bda804fcf44c0ec6b3bf75d9a.tar.bz2
gentoo-9149a2e696c66a4bda804fcf44c0ec6b3bf75d9a.zip
net-p2p/qbittorrent: add 4.5.2
Bug: https://bugs.gentoo.org/898508 Signed-off-by: Joe Kappus <joe@wt.gd> Closes: https://github.com/gentoo/gentoo/pull/29864 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 7ae9a277ae21..742e3b0d6867 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,2 +1,3 @@
DIST qbittorrent-4.4.5.tar.gz 7739170 BLAKE2B b40a3ca63c787e0b9b9aac00a6fef452b461ba36b1ef030bc3cdd5fbefcca42d58ff6c3bd382e49f7937161afc6a37bc2c29de4f804db10c7031b9f1ad5f4e2b SHA512 a2b6ecd9a6f087a7ecaad2774d395ee4b2164cb8540b9f32574640f485fa3fc8688046d30e0179863a0aff1524d69b83c00bc232c7feb9ad737c79a05734ad95
DIST qbittorrent-4.5.1.tar.gz 8780065 BLAKE2B 5c910722d778272972b90f8a2680b0450ea4220a760335e09bf078a63bbdc0c35788de6d75375c4de808582f386cc7d4c372b87d3a6308aa41f575a72927de5e SHA512 46042e55618b9bb24b61b88695a2ab01e5aef39fcad465d47aabe9965d2b66c96e0f35af49bb19b597c009de5b844969819d9dc700b883b1c0d99e2b9671f405
+DIST qbittorrent-4.5.2.tar.gz 8890525 BLAKE2B 48585b703ce6edf862ea3c8cfad6cab2edcb65a138c6e8d232322b4f4fd682c87447ff11d29c04c26b5623e730ab9a1ce0496456b3ba6122f97913bd92b86790 SHA512 e900a1c5f0f70163463557aec3de0d31394fac56cfed91ea53ee5cf852cce4b2998bf79be60fc547c1c34a1658378f3ed9dbfb30aae5a772b85d819c7e7ce458
diff --git a/net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild b/net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild
new file mode 100644
index 000000000000..47567072162d
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake multibuild systemd xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/qbittorrent/qBittorrent.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/qBittorrent-release-${PV}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus +gui webui"
+REQUIRED_USE="dbus? ( gui )
+ || ( gui webui )"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/openssl-1.1.1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtxml:5
+ <net-libs/libtorrent-rasterbar-2:=
+ >=sys-libs/zlib-1.2.11
+ dbus? ( dev-qt/qtdbus:5 )
+ gui? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md )
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ multibuild_src_configure() {
+ local mycmakeargs=(
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+
+ # Not yet in ::gentoo
+ -DQT6=OFF
+
+ -DWEBUI=$(usex webui)
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == gui ]]; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=(
+ -DGUI=ON
+ -DDBUS=$(usex dbus)
+ -DSYSTEMD=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DDBUS=OFF
+ # The systemd service calls qbittorrent-nox, which is only
+ # installed when GUI=OFF.
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR="$(systemd_get_systemunitdir)"
+ )
+ fi
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant multibuild_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+ einstalldocs
+}