summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-09-10 08:56:30 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-09-10 08:57:49 -0500
commitba313b756eb1d6903c621702778204aa515c7618 (patch)
tree2c6bcbe10027fa47ea983e1b85c3213b2cd536d5 /net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
parentapp-emulation/spice: Call addpredict in appropriate function, bug #593388 (diff)
downloadgentoo-ba313b756eb1d6903c621702778204aa515c7618.tar.gz
gentoo-ba313b756eb1d6903c621702778204aa515c7618.tar.bz2
gentoo-ba313b756eb1d6903c621702778204aa515c7618.zip
net-misc/spice-gtk: Call addpredict in appropriate functions, bug #593388
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild')
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild b/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
index ea87c5ac53e0..7477ddfe6cce 100644
--- a/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
@@ -79,10 +79,6 @@ DEPEND="${RDEPEND}
# dev-lang/vala:0.14
# dev-lang/perl
-# Prevent sandbox violations, bug #581836
-# https://bugzilla.gnome.org/show_bug.cgi?id=581836
-addpredict /dev
-
src_prepare() {
epatch "${FILESDIR}"/${P}-x11-libs.patch
epatch_user
@@ -93,6 +89,11 @@ src_prepare() {
}
src_configure() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
local myconf
if use vala ; then
@@ -125,6 +126,15 @@ src_configure() {
econf ${myconf}
}
+src_compile() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ default
+}
+
src_install() {
default