summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-09-06 11:47:41 -0400
committerCraig Andrews <candrews@gentoo.org>2023-09-06 11:48:08 -0400
commit6d604269a6b935cc3feedb961a300169c59e5d78 (patch)
treebdedec4b1967255b7e10c9660ae24298e57598d7 /net-misc/nyx
parentdev-perl/Net-IDN-Encode: Stabilize 2.500.0-r2 arm64, #913716 (diff)
downloadgentoo-6d604269a6b935cc3feedb961a300169c59e5d78.tar.gz
gentoo-6d604269a6b935cc3feedb961a300169c59e5d78.tar.bz2
gentoo-6d604269a6b935cc3feedb961a300169c59e5d78.zip
net-misc/nyx: Simplify net-libs/stem dependency
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-misc/nyx')
-rw-r--r--net-misc/nyx/nyx-2.1.0-r6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/nyx/nyx-2.1.0-r6.ebuild b/net-misc/nyx/nyx-2.1.0-r6.ebuild
new file mode 100644
index 000000000000..4211aadc685b
--- /dev/null
+++ b/net-misc/nyx/nyx-2.1.0-r6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='ncurses,sqlite(-)'
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+ inherit pypi
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# net-libs/stem-1.8.0_p20211118 was an incompatible git-snapshot
+# simply depend on net-libs/stem in the future
+RDEPEND="
+ net-libs/stem[${PYTHON_USEDEP}]
+ net-vpn/tor"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # bug #645336
+ doman nyx.1
+}