summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-22 22:18:38 +0000
committerSam James <sam@gentoo.org>2021-03-23 04:48:40 +0000
commitad04f60b47f190af3669bd224e6056b11249fca9 (patch)
treeb8c8250be5e83a01d1df8b391bfb0b7edc9022e4 /net-misc/iperf/iperf-3.9-r1.ebuild
parentnet-analyzer/vnstat: port to EAPI 7 (diff)
downloadgentoo-ad04f60b47f190af3669bd224e6056b11249fca9.tar.gz
gentoo-ad04f60b47f190af3669bd224e6056b11249fca9.tar.bz2
gentoo-ad04f60b47f190af3669bd224e6056b11249fca9.zip
net-misc/iperf: minor style changes
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/iperf/iperf-3.9-r1.ebuild')
-rw-r--r--net-misc/iperf/iperf-3.9-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-misc/iperf/iperf-3.9-r1.ebuild b/net-misc/iperf/iperf-3.9-r1.ebuild
index d53aca6f6b77..2c1fd2153029 100644
--- a/net-misc/iperf/iperf-3.9-r1.ebuild
+++ b/net-misc/iperf/iperf-3.9-r1.ebuild
@@ -2,10 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit systemd
DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
-HOMEPAGE="https://github.com/esnet/iperf/"
+HOMEPAGE="https://github.com/esnet/iperf"
SRC_URI="https://github.com/esnet/iperf/archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/}"
@@ -21,7 +22,7 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-DOCS=( "README.md" "RELNOTES.md" )
+DOCS=( README.md RELNOTES.md )
src_configure() {
econf \
@@ -35,5 +36,6 @@ src_install() {
newconfd "${FILESDIR}"/iperf.confd iperf3
newinitd "${FILESDIR}"/iperf3.initd iperf3
systemd_dounit contrib/iperf3.service
+
find "${ED}" -name '*.la' -delete || die
}