summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-19 05:17:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-19 05:21:45 -0400
commit82879c233f6f8be1e6626a2b44718a6ba4fc14b3 (patch)
treede539d8cfe4eb8bc5e9dfecadac420c238edfb9e /net-misc/getdate
parentsci-biology/trnascan-se: fix build w/ clang16, pass -std=gnu89 (diff)
downloadgentoo-82879c233f6f8be1e6626a2b44718a6ba4fc14b3.tar.gz
gentoo-82879c233f6f8be1e6626a2b44718a6ba4fc14b3.tar.bz2
gentoo-82879c233f6f8be1e6626a2b44718a6ba4fc14b3.zip
net-misc/getdate: fix build w/ upcoming clang16
Closes: https://bugs.gentoo.org/874501 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/getdate')
-rw-r--r--net-misc/getdate/files/getdate-1.2-clang16.patch8
-rw-r--r--net-misc/getdate/getdate-1.2-r2.ebuild3
2 files changed, 10 insertions, 1 deletions
diff --git a/net-misc/getdate/files/getdate-1.2-clang16.patch b/net-misc/getdate/files/getdate-1.2-clang16.patch
new file mode 100644
index 000000000000..7b578e37bb26
--- /dev/null
+++ b/net-misc/getdate/files/getdate-1.2-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/874501
+--- a/getdate.c
++++ b/getdate.c
+@@ -250,3 +250,3 @@
+
+-main (int argc, char *argv[])
++int main (int argc, char *argv[])
+ {
diff --git a/net-misc/getdate/getdate-1.2-r2.ebuild b/net-misc/getdate/getdate-1.2-r2.ebuild
index 21c21d60ba86..d06f3c2be84e 100644
--- a/net-misc/getdate/getdate-1.2-r2.ebuild
+++ b/net-misc/getdate/getdate-1.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}/${PN}-glibc-2.31.patch"
+ "${FILESDIR}/${P}-clang16.patch"
)
src_prepare() {