summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-10 09:34:32 +0000
committerSam James <sam@gentoo.org>2021-05-10 09:34:32 +0000
commita7cb56cec9707622e9ea44ad9422d3486a410f00 (patch)
tree644b498f2934edd917a85246194fbb75b1741c37 /net-libs
parentnet-libs/libmicrohttpd: new upstream version 0.9.73 (diff)
downloadgentoo-a7cb56cec9707622e9ea44ad9422d3486a410f00.tar.gz
gentoo-a7cb56cec9707622e9ea44ad9422d3486a410f00.tar.bz2
gentoo-a7cb56cec9707622e9ea44ad9422d3486a410f00.zip
net-libs/libmicrohttpd: misc fixes
* Move pkgconfig out of DEPEND into BDEPEND * Missing || die * Use array for DOCS Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.73.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.73.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.73.ebuild
index b86323177805..6e40bbf9a525 100644
--- a/net-libs/libmicrohttpd/libmicrohttpd-0.9.73.ebuild
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.73.ebuild
@@ -10,6 +10,7 @@ MY_P="${P/_/}"
DESCRIPTION="Small C library to run an HTTP server as part of another application"
HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="LGPL-2.1"
SLOT="0/12"
@@ -17,21 +18,15 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc
IUSE="+epoll ssl static-libs test thread-names"
RESTRICT="!test? ( test )"
-BDEPEND="
- ssl? ( virtual/pkgconfig )
- test? ( virtual/pkgconfig )
- "
-
RDEPEND="ssl? ( >net-libs/gnutls-2.12.20:= )"
-
DEPEND="${RDEPEND}
test? ( net-misc/curl[ssl?] )
+"
+BDEPEND="
virtual/pkgconfig
- "
-
-S=${WORKDIR}/${MY_P}
+"
-DOCS="AUTHORS NEWS README ChangeLog"
+DOCS=( AUTHORS NEWS README ChangeLog )
multilib_src_configure() {
ECONF_SOURCE="${S}" \
@@ -57,5 +52,7 @@ multilib_src_configure() {
multilib_src_install_all() {
default
- use static-libs || find "${ED}" -name '*.la' -delete
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
}