summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/liblockfile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/liblockfile')
-rw-r--r--net-libs/liblockfile/Manifest1
-rw-r--r--net-libs/liblockfile/files/Makefile.Darwin.in80
-rw-r--r--net-libs/liblockfile/files/liblockfile-1.06-respectflags.patch18
-rw-r--r--net-libs/liblockfile/files/liblockfile-orphan-file.patch19
-rw-r--r--net-libs/liblockfile/liblockfile-1.09.ebuild48
-rw-r--r--net-libs/liblockfile/metadata.xml5
6 files changed, 171 insertions, 0 deletions
diff --git a/net-libs/liblockfile/Manifest b/net-libs/liblockfile/Manifest
new file mode 100644
index 000000000000..6a0458b09b61
--- /dev/null
+++ b/net-libs/liblockfile/Manifest
@@ -0,0 +1 @@
+DIST liblockfile_1.09.orig.tar.gz 32178 SHA256 16979eba05396365e1d6af7100431ae9d32f9bc063930d1de66298a0695f1b7f SHA512 8577f8bfa9c78983d6a409bc449be0d981e599a6a5f2fc8b43f76a238810ec5e3c180e27280719398f31041ed837fe8ba61df208ce77db77a354453e4579848a WHIRLPOOL 4365bd4f90207a97ec8421f60bcf2d61c4565eecc9435fd920b31ede3e182856783d21ad466632ea8d18e0378f3401637185235ef90e50d6bc10d093ae4d8a42
diff --git a/net-libs/liblockfile/files/Makefile.Darwin.in b/net-libs/liblockfile/files/Makefile.Darwin.in
new file mode 100644
index 000000000000..bdd320fe6d49
--- /dev/null
+++ b/net-libs/liblockfile/files/Makefile.Darwin.in
@@ -0,0 +1,80 @@
+#
+# Makefile.in Makefile for the liblockfile package (Darwin version)
+#
+# Gentoo version for Darwin, based on original:
+# version: @(#)Makefile.in 1.01 16-Apr-1999 miquels@cistron.nl
+#
+
+VER = 1.0
+NVER = 0.1
+
+CFLAGS = @CFLAGS@ -I.
+LDFLAGS = @LDFLAGS@
+CC = @CC@
+
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+bindir = @bindir@
+libdir = @libdir@
+mandir = @mandir@
+nfslockdir = @nfslockdir@
+includedir = @includedir@
+
+MAILGROUP = @MAILGROUP@
+
+all: @TARGETS@
+install: @INSTALL_TARGETS@
+
+static: liblockfile.a dotlockfile
+shared: liblockfile.dylib dotlockfile
+nfslib: nfslock.$(VER).dylib
+
+liblockfile.a: lockfile.o
+ ar rv liblockfile.a lockfile.o
+
+liblockfile.dylib: liblockfile.a
+ $(CC) $(LDFLAGS) -fPIC -dynamiclib -install_name @libdir@/liblockfile.1.0.dylib \
+ -o liblockfile.dylib lockfile.o -lc
+
+nfslock.$(VER).dylib: nfslock.o
+ $(CC) $(LDFLAGS) -fPIC -dynamiclib -install_name nfslock.0.dylib \
+ -o nfslock.$(NVER).dylib nfslock.o
+
+dotlockfile: dotlockfile.o xlockfile.o
+ $(CC) $(LDFLAGS) -o dotlockfile dotlockfile.o xlockfile.o
+
+lockfile.o: lockfile.c
+ $(CC) $(CFLAGS) -DLIB -DLOCKPROG=\"$(bindir)/dotlockfile\" \
+ -c lockfile.c
+
+xlockfile.o: lockfile.c
+ $(CC) $(CFLAGS) -c lockfile.c -o xlockfile.o
+
+install_static: static install_common
+ install -m 644 liblockfile.a $(ROOT)$(libdir)
+
+install_shared: shared install_common
+ install -m 755 liblockfile.dylib \
+ $(ROOT)$(libdir)/liblockfile.$(VER).dylib
+ ln -s liblockfile.$(VER).dylib $(ROOT)$(libdir)/liblockfile.dylib
+
+install_common:
+ install -m 644 lockfile.h maillock.h $(ROOT)$(includedir)
+ if [ "$(MAILGROUP)" != "" ]; then\
+ install -g $(MAILGROUP) -m 2755 dotlockfile $(ROOT)$(bindir);\
+ else \
+ install -g root -m 755 dotlockfile $(ROOT)$(bindir); \
+ fi
+ install -m 644 *.1 $(ROOT)$(mandir)/man1
+ install -m 644 *.3 $(ROOT)$(mandir)/man3
+
+install_nfslib: nfslib
+ install -m 755 nfslock.$(VER).dylib $(ROOT)$(nfslockdir)
+
+clean:
+ rm -f *.a *.o *.dylib dotlockfile
+
+distclean: clean
+ rm -f Makefile autoconf.h maillock.h \
+ config.cache config.log config.status
+
diff --git a/net-libs/liblockfile/files/liblockfile-1.06-respectflags.patch b/net-libs/liblockfile/files/liblockfile-1.06-respectflags.patch
new file mode 100644
index 000000000000..1a8d0eb18cbe
--- /dev/null
+++ b/net-libs/liblockfile/files/liblockfile-1.06-respectflags.patch
@@ -0,0 +1,18 @@
+Index: liblockfile-1.06/Makefile.in
+===================================================================
+--- liblockfile-1.06.orig/Makefile.in
++++ liblockfile-1.06/Makefile.in
+@@ -32,11 +32,11 @@ liblockfile.a: lockfile.o
+ ar rv liblockfile.a lockfile.o
+
+ liblockfile.so: liblockfile.a
+- $(CC) -fPIC -shared -Wl,-soname,liblockfile.so.1 \
++ $(CC) $(LDFLAGS) -fPIC -shared -Wl,-soname,liblockfile.so.1 \
+ -o liblockfile.so lockfile.o -lc
+
+ nfslock.so.$(VER): nfslock.o
+- $(CC) -fPIC -shared -Wl,-soname,nfslock.so.0 \
++ $(CC) $(LDFLAGS) -fPIC -shared -Wl,-soname,nfslock.so.0 \
+ -o nfslock.so.$(NVER) nfslock.o
+
+ dotlockfile: dotlockfile.o xlockfile.o
diff --git a/net-libs/liblockfile/files/liblockfile-orphan-file.patch b/net-libs/liblockfile/files/liblockfile-orphan-file.patch
new file mode 100644
index 000000000000..4a8c75ac4129
--- /dev/null
+++ b/net-libs/liblockfile/files/liblockfile-orphan-file.patch
@@ -0,0 +1,19 @@
+diff -ur liblockfile-1.06-orig/Makefile.in liblockfile-1.06/Makefile.in
+--- liblockfile-1.06-orig/Makefile.in 2006-11-28 06:19:09.000000000 +0100
++++ liblockfile-1.06/Makefile.in 2006-11-28 06:24:30.000000000 +0100
+@@ -5,6 +5,7 @@
+ #
+
+ VER = 1.0
++MVER = 1
+ NVER = 0.1
+
+ CFLAGS = @CFLAGS@ -I.
+@@ -55,6 +56,7 @@
+ install_shared: shared install_common
+ install -m 755 liblockfile.so \
+ $(ROOT)$(libdir)/liblockfile.so.$(VER)
++ ln -s liblockfile.so.$(VER) $(ROOT)$(libdir)/liblockfile.so.$(MVER)
+ ln -s liblockfile.so.$(VER) $(ROOT)$(libdir)/liblockfile.so
+ if test "$(ROOT)" = ""; then @LDCONFIG@; fi
+
diff --git a/net-libs/liblockfile/liblockfile-1.09.ebuild b/net-libs/liblockfile/liblockfile-1.09.ebuild
new file mode 100644
index 000000000000..8d7481ade6d4
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.09.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib autotools user
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+pkg_setup() {
+ enewgroup mail 12
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.06-respectflags.patch
+ epatch "${FILESDIR}"/${PN}-orphan-file.patch
+
+ # I don't feel like making the Makefile portable
+ [[ ${CHOST} == *-darwin* ]] \
+ && cp "${FILESDIR}"/Makefile.Darwin.in Makefile.in
+
+ eautoreconf
+}
+
+src_configure() {
+ local grp=mail
+ if use prefix ; then
+ # we never want to use LDCONFIG
+ export LDCONFIG=${EPREFIX}/bin/true
+ # in unprivileged installs this is "mail"
+ grp=$(id -g)
+ fi
+ econf --with-mailgroup=${grp} --enable-shared
+}
+
+src_install() {
+ dodir /usr/{bin,include,$(get_libdir)} /usr/share/man/{man1,man3}
+ emake ROOT="${D}" install
+ dodoc README Changelog
+}
diff --git a/net-libs/liblockfile/metadata.xml b/net-libs/liblockfile/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/net-libs/liblockfile/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>