summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-13 08:44:59 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-13 10:44:12 +0100
commit5334c986122aabfefc272f4d97de1753750ae3ad (patch)
tree4b08c2388cbe4ddaa04813a7104b7afa012c7520 /net-libs/libbloom/libbloom-1.5-r1.ebuild
parentsys-kernel/linux-headers: bump up to 4.18, bug #668306 (diff)
downloadgentoo-5334c986122aabfefc272f4d97de1753750ae3ad.tar.gz
gentoo-5334c986122aabfefc272f4d97de1753750ae3ad.tar.bz2
gentoo-5334c986122aabfefc272f4d97de1753750ae3ad.zip
net-libs/libbloom: fix build on 32-bit systems
The change adapts build system to be friendlier to Gentoo envorinment: - avoid passing '-m64' unconditionally. Fixes build on ARCH=x86. - avoid passing -O3 unconditionally. Rely on users' optimization flags. - pass user's CC. Fixes simple cross-compilation case. Patch by Zhaofeng Li. Closes: https://bugs.gentoo.org/658466 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs/libbloom/libbloom-1.5-r1.ebuild')
-rw-r--r--net-libs/libbloom/libbloom-1.5-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libbloom/libbloom-1.5-r1.ebuild b/net-libs/libbloom/libbloom-1.5-r1.ebuild
new file mode 100644
index 000000000000..7e255245ef90
--- /dev/null
+++ b/net-libs/libbloom/libbloom-1.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple and small bloom filter implementation in plain C."
+HOMEPAGE="https://github.com/jvirkki/libbloom"
+SRC_URI="https://github.com/jvirkki/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC=$(tc-getCC) BITS=default OPT=
+}
+
+src_install() {
+ doheader bloom.h
+ dolib.so build/${PN}.so*
+}