summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-07 15:15:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-14 23:55:29 +0100
commit056769a59ea49665ba959759fb7b4f9f7dfb9553 (patch)
tree26dde08d1db3e4e417a0b11f647b558fc4bbe888 /net-libs/kdsoap-ws-discovery-client
parentmedia-video/subtitlecomposer: add 0.8.0 (diff)
downloadgentoo-056769a59ea49665ba959759fb7b4f9f7dfb9553.tar.gz
gentoo-056769a59ea49665ba959759fb7b4f9f7dfb9553.tar.bz2
gentoo-056769a59ea49665ba959759fb7b4f9f7dfb9553.zip
net-libs/kdsoap-ws-discovery-client: add 0.3.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/kdsoap-ws-discovery-client')
-rw-r--r--net-libs/kdsoap-ws-discovery-client/Manifest1
-rw-r--r--net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.3.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/kdsoap-ws-discovery-client/Manifest b/net-libs/kdsoap-ws-discovery-client/Manifest
index d9b499b3b6ec..1551a85a33c3 100644
--- a/net-libs/kdsoap-ws-discovery-client/Manifest
+++ b/net-libs/kdsoap-ws-discovery-client/Manifest
@@ -1 +1,2 @@
DIST kdsoap-ws-discovery-client-0.2_pre20200927.tar.gz 37493 BLAKE2B c0dff21554bc56c4055c74a166a85186d67b0378f7bfbfcd3582ae7b992aaa71cefb6b794258fa07b37fcdd1d42ac2bf9fbfd7cd8142f8f77b1ba9791d683dae SHA512 86f8c4eee3fd484253ee91190092a9ae0dbd3d0c536ec25a6e3ec35be45d4a3d320cffbfc0ed2024d447788b43c9df88ca81181157720ce8942c9034d4eea49f
+DIST kdsoap-ws-discovery-client-0.3.0.tar.xz 30948 BLAKE2B e8a9e0f0cb3eee9e942436b4a8d07d7b8ab6578fecd5b3d59aadee7af91268945c4b4c37619212fb0f54038de65d38b318c33717f3e0eff07b088a101a0d72c6 SHA512 24c437686fc7d6659f610d030b263cef33c35e4c4f4f8a750068d3b2dcd166142d32d21c3d15a14f6ec7eb87b28d883d1d1ba8e11497ea75a1328e29a256a5c8
diff --git a/net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.3.0.ebuild b/net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.3.0.ebuild
new file mode 100644
index 000000000000..b8b71ffcdab1
--- /dev/null
+++ b/net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+inherit ecm kde.org
+
+DESCRIPTION="WS-Discovery client library based on KDSoap"
+HOMEPAGE="https://invent.kde.org/libraries/kdsoap-ws-discovery-client"
+SRC_URI="mirror://kde/unstable/${PN/discovery/discover}/${P}.tar.xz"
+
+LICENSE="CC0-1.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="doc"
+
+RESTRICT="test"
+
+RDEPEND="
+ dev-qt/qtnetwork:5
+ >=net-libs/kdsoap-2.0.0:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qtxml:5 )
+"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2_pre20200317-no-install-docs.patch )
+
+src_prepare() {
+ ecm_src_prepare
+ use test || ecm_punt_qt_module Xml
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package doc Doxygen)
+ -DBUILD_QCH=OFF # does not use ecm_add_qch from ECMAddQch
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ ecm_src_install
+}