summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-21 13:15:37 +0000
committerSam James <sam@gentoo.org>2021-03-21 13:16:29 +0000
commit53c0b6ffcebc589e9df56dafea59877ac9ef4c5f (patch)
tree5927a596d249686e9f708292ffe19e8a312b5184 /net-libs/glib-networking
parentdev-lang/clojure: use ver_cut for maintainability (diff)
downloadgentoo-53c0b6ffcebc589e9df56dafea59877ac9ef4c5f.tar.gz
gentoo-53c0b6ffcebc589e9df56dafea59877ac9ef4c5f.tar.bz2
gentoo-53c0b6ffcebc589e9df56dafea59877ac9ef4c5f.zip
net-libs/glib-networking: build tests conditionally
Closes: https://bugs.gentoo.org/777462 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/glib-networking')
-rw-r--r--net-libs/glib-networking/glib-networking-2.68.0.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/net-libs/glib-networking/glib-networking-2.68.0.ebuild b/net-libs/glib-networking/glib-networking-2.68.0.ebuild
index 77f31df6c8c9..5d4e94cae8f7 100644
--- a/net-libs/glib-networking/glib-networking-2.68.0.ebuild
+++ b/net-libs/glib-networking/glib-networking-2.68.0.ebuild
@@ -30,6 +30,19 @@ BDEPEND="
test? ( sys-apps/dbus )
"
+src_prepare() {
+ xdg_src_prepare
+
+ if ! use test ; then
+ # Don't build tests unconditionally
+ # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
+ # It may become a real runtime dependency in future
+ # Please check!
+ # bug #777462
+ sed -i "/^subdir('tls\/tests')/d" meson.build || die
+ fi
+}
+
multilib_src_configure() {
local emesonargs=(
-Dgnutls=enabled