summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-10-29 14:19:42 +0100
committerLouis Sautier <sbraz@gentoo.org>2023-11-07 13:29:24 +0100
commitddb728b7158dc39af5d63ab1a4d00b803e673e24 (patch)
tree0f868ef44a8713aad18cc8d712e0c7faf359bf7b /net-irc/znc
parentapp-editors/vscode: add 1.84.1 (diff)
downloadgentoo-ddb728b7158dc39af5d63ab1a4d00b803e673e24.tar.gz
gentoo-ddb728b7158dc39af5d63ab1a4d00b803e673e24.tar.bz2
gentoo-ddb728b7158dc39af5d63ab1a4d00b803e673e24.zip
net-irc/znc: add new dependency on argon2 + enable py312
Argon2 is now used to hash passwords instead of SHA-256. Also fix dependency on Python: it is also required to run tests because znc-buildmod is a Python script. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/znc-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-irc/znc/znc-9999.ebuild b/net-irc/znc/znc-9999.ebuild
index a247a1966b36..1f2334900220 100644
--- a/net-irc/znc/znc-9999.ebuild
+++ b/net-irc/znc/znc-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-single-r1 readme.gentoo-r1 systemd
@@ -33,7 +33,11 @@ SLOT="0/${PV}"
IUSE="+icu nls perl python +ssl sasl tcl test +zlib"
RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} icu )"
+# tests run znc-buildmod which is a Python script
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} icu )
+ test? ( ${PYTHON_REQUIRED_USE} )
+"
# perl is a build-time dependency of modpython
BDEPEND="
@@ -53,6 +57,7 @@ BDEPEND="
)
"
DEPEND="
+ app-crypt/argon2
icu? ( dev-libs/icu:= )
nls? ( dev-libs/boost:=[nls] )
perl? ( >=dev-lang/perl-5.10:= )
@@ -73,7 +78,7 @@ PATCHES=(
)
pkg_setup() {
- if use python; then
+ if use python || use test; then
python-single-r1_pkg_setup
fi
}