summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-17 22:51:45 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-17 22:52:13 +0200
commit470cab9984805c6134d14f3b83d04cc536c89d30 (patch)
treec439df01ee524215108291ed2012d3c60b35afeb /net-firewall/firehol/firehol-3.1.3.ebuild
parentpackage.mask: Last rite sys-block/{lio-utils,rtsadmin} (diff)
downloadgentoo-470cab9984805c6134d14f3b83d04cc536c89d30.tar.gz
gentoo-470cab9984805c6134d14f3b83d04cc536c89d30.tar.bz2
gentoo-470cab9984805c6134d14f3b83d04cc536c89d30.zip
net-firewall/firehol: version bump
Bug: 609626 Package-Manager: portage-2.3.3
Diffstat (limited to 'net-firewall/firehol/firehol-3.1.3.ebuild')
-rw-r--r--net-firewall/firehol/firehol-3.1.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-firewall/firehol/firehol-3.1.3.ebuild b/net-firewall/firehol/firehol-3.1.3.ebuild
new file mode 100644
index 000000000000..ef292052a46e
--- /dev/null
+++ b/net-firewall/firehol/firehol-3.1.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils linux-info
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="https://github.com/firehol/firehol"
+SRC_URI="https://github.com/firehol/firehol/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc ipv6"
+KEYWORDS="~amd64 ~arm"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2[-minimal,ipv6?]
+ net-misc/iputils[ipv6?]
+ net-misc/iprange
+ net-analyzer/traceroute
+ virtual/modutils
+ app-arch/gzip"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ local KCONFIG_OPTS=" \
+ ~IP_NF_FILTER \
+ ~IP_NF_IPTABLES \
+ ~IP_NF_MANGLE \
+ ~IP_NF_TARGET_MASQUERADE
+ ~IP_NF_TARGET_REDIRECT \
+ ~IP_NF_TARGET_REJECT \
+ ~NETFILTER_XT_MATCH_LIMIT \
+ ~NETFILTER_XT_MATCH_OWNER \
+ ~NETFILTER_XT_MATCH_STATE \
+ ~NF_CONNTRACK \
+ ~NF_CONNTRACK_IPV4 \
+ ~NF_CONNTRACK_MARK \
+ ~NF_NAT \
+ ~NF_NAT_FTP \
+ ~NF_NAT_IRC \
+ "
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --disable-vnetbuild \
+ --disable-update-ipsets \
+ $(use_enable doc) \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/firehol.conf.d firehol
+ newinitd "${FILESDIR}"/firehol.initrd firehol
+ newconfd "${FILESDIR}"/fireqos.conf.d fireqos
+ newinitd "${FILESDIR}"/fireqos.initrd fireqos
+}