summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-16 18:54:34 +0000
committerSam James <sam@gentoo.org>2024-08-31 08:10:14 +0100
commit654c7d2780ac64a43e9ee0c04e0964a110755f5a (patch)
tree740b252f2581f9732a962b5cc74b06868aa35f80 /net-dns
parentnet-dns/bind: use standard USE=test (diff)
downloadgentoo-654c7d2780ac64a43e9ee0c04e0964a110755f5a.tar.gz
gentoo-654c7d2780ac64a43e9ee0c04e0964a110755f5a.tar.bz2
gentoo-654c7d2780ac64a43e9ee0c04e0964a110755f5a.zip
net-dns/bind: restore USE=jemalloc
We can't force jemalloc because bind-tools (which this now blocks, and installs the same tools as, and we may end up just using net-dns/bind for all of it) needs to be usable in as many places as possible and jemalloc isn't ported to all arches. We can therefore restore ~sparc. Bug: https://bugs.gentoo.org/832218 Bug: https://bugs.gentoo.org/930348 Bug: https://bugs.gentoo.org/936568 Bug: https://bugs.gentoo.org/937907 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/bind-9.18.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-dns/bind/bind-9.18.0.ebuild b/net-dns/bind/bind-9.18.0.ebuild
index a9242a3570fb..2174fab36659 100644
--- a/net-dns/bind/bind-9.18.0.ebuild
+++ b/net-dns/bind/bind-9.18.0.ebuild
@@ -18,14 +18,13 @@ SRC_URI="https://downloads.isc.org/isc/bind9/${PV}/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+caps dnsrps dnstap doc doh fixed-rrset idn geoip gssapi lmdb selinux static-libs test xml"
RESTRICT="!test? ( test )"
DEPEND="
acct-group/named
acct-user/named
- dev-libs/jemalloc
dev-libs/json-c:=
dev-libs/libuv:=
sys-libs/zlib
@@ -36,6 +35,7 @@ DEPEND="
geoip? ( dev-libs/libmaxminddb )
gssapi? ( virtual/krb5 )
idn? ( net-dns/libidn2 )
+ jemalloc? ( dev-libs/jemalloc:= )
lmdb? ( dev-db/lmdb )
xml? ( dev-libs/libxml2 )
"
@@ -63,7 +63,6 @@ src_configure() {
--enable-full-report
--without-readline
--with-openssl="${ESYSROOT}"/usr
- --with-jemalloc
--with-json-c
--with-zlib
$(use_enable caps linux-caps)
@@ -77,9 +76,9 @@ src_configure() {
$(use_with geoip maxminddb)
$(use_with gssapi)
$(use_with idn libidn2)
+ $(use_with jemalloc)
$(use_with lmdb)
$(use_with xml libxml2)
- "${@}"
)
econf "${myeconfargs[@]}"