summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2023-03-08 08:36:54 +0100
committerSven Wegener <swegener@gentoo.org>2023-03-08 08:37:59 +0100
commit33a693fc973e35defabf3d60c7fca5c7c3b72a55 (patch)
treee3db8b576158a3d7c3c86a74cd18694937c54d59 /net-dns/pdns-recursor
parentnet-misc/udpcast: restore FEC (diff)
downloadgentoo-33a693fc973e35defabf3d60c7fca5c7c3b72a55.tar.gz
gentoo-33a693fc973e35defabf3d60c7fca5c7c3b72a55.tar.bz2
gentoo-33a693fc973e35defabf3d60c7fca5c7c3b72a55.zip
net-dns/pdns-recursor: add 4.8.3
Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.8.3.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 89d288529745..06c5f7f000de 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,2 +1,3 @@
DIST pdns-recursor-4.7.4.tar.bz2 1609031 BLAKE2B b051a77f1c734546b26c3bb0030c0e57ee4621b14f0e92d7d294fb80fde599aa813f56a64750e1a00587fee8f05aa9ae1def94f3c3709b103223ed48124b66a7 SHA512 51ecccb557a5a9f3aa28144b60ab75b0fe5534bb2534b0a44662b474a01a0fae61f08b8ca787fc27f22b2a89b721ae66e1a954c4ceb829e66f89f286d5e174a8
DIST pdns-recursor-4.8.2.tar.bz2 1532488 BLAKE2B 697b1981f0ae9ef8823f8f8cd09f31083d5924fda9ce153eda25ffe0abf67bd92d972946e58d3f2ffc8cf822693cdd759915fdd148a457dc0659424c346455bd SHA512 024d3e2bc784dc29208be6640bd0c74d296f72d0753a2f9bb0b8befc7abe08e8c1852fc707ddf17562c8b333329646c3a9e6e059c46188b2acf3b6b4e28a246f
+DIST pdns-recursor-4.8.3.tar.bz2 1525607 BLAKE2B 3051f272602ac80e38ce1166f28cb57d6e57213121f52f7a0b00dc564fe07fd2e9d26e3d3401560e9249e06f6b28c29859d1a86693d4f4864c16b9ad304f29d2 SHA512 ed38315cae26237ebab8932710d3d9badaea51367a1e68842daef213f28c0ba2e12e7c141234055e585f08195c42b466320af8bad527245e2aaf57ec1bd35f2d
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.8.3.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.8.3.ebuild
new file mode 100644
index 000000000000..6789d8a0e920
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.8.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ elibc_glibc? (
+ arm? ( >=sys-libs/glibc-2.34 )
+ x86? ( >=sys-libs/glibc-2.34 )
+ )
+ dev-libs/openssl:=
+ dev-libs/boost:=[context]"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}