summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2015-11-30 07:13:41 +0100
committerSlawomir Lis <slis@gentoo.org>2015-11-30 07:13:41 +0100
commit1cccc7fc24794b31f27225822e9017bdf39187e5 (patch)
tree4a2923d5d9cf076e0b038abff55e74640d86b663 /net-analyzer
parentdev-libs/libpcre: Stable for HPPA (bug #553300). (diff)
downloadgentoo-1cccc7fc24794b31f27225822e9017bdf39187e5.tar.gz
gentoo-1cccc7fc24794b31f27225822e9017bdf39187e5.tar.bz2
gentoo-1cccc7fc24794b31f27225822e9017bdf39187e5.zip
Added suricata ebuild (#437564)
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/suricata/Manifest1
-rw-r--r--net-analyzer/suricata/files/fortify_source-numeric.patch11
-rw-r--r--net-analyzer/suricata/files/json.patch10
-rw-r--r--net-analyzer/suricata/files/magic-location.patch13
-rw-r--r--net-analyzer/suricata/metadata.xml16
-rw-r--r--net-analyzer/suricata/suricata-2.0.10.ebuild119
6 files changed, 170 insertions, 0 deletions
diff --git a/net-analyzer/suricata/Manifest b/net-analyzer/suricata/Manifest
new file mode 100644
index 000000000000..77f17d08edeb
--- /dev/null
+++ b/net-analyzer/suricata/Manifest
@@ -0,0 +1 @@
+DIST suricata-2.0.10.tar.gz 3090730 SHA256 c8d1d3b6ce3d2a56577fca224424071afd921739d3859efc8a62229556d4beef SHA512 fa3683a93d85b26166b0f67a85f1a498941aadf4372ef98bd7fe62fcdef150af46b65456e3a764e054c385abbf44138ae6f70882c68ba320508eade6e181f2c6 WHIRLPOOL b867003e76df2b0b1b56c89415ed96acbf9d8966739d77aa303055d29ae5cdad8ad0b58e969336f0c1fc2e5d9990941622c19c062828dae58bf062f5662225f3
diff --git a/net-analyzer/suricata/files/fortify_source-numeric.patch b/net-analyzer/suricata/files/fortify_source-numeric.patch
new file mode 100644
index 000000000000..0a7f4827ea05
--- /dev/null
+++ b/net-analyzer/suricata/files/fortify_source-numeric.patch
@@ -0,0 +1,11 @@
+--- a/src/suricata.c 2015-10-02 00:21:55.634213646 +0200
++++ b/src/suricata.c 2015-10-02 00:22:39.143940007 +0200
+@@ -774,7 +774,7 @@
+ printf("compiled with -fstack-protector-all\n");
+ #endif
+ #ifdef _FORTIFY_SOURCE
+- printf("compiled with _FORTIFY_SOURCE=%d\n", _FORTIFY_SOURCE);
++ printf("compiled with _FORTIFY_SOURCE\n");
+ #endif
+ #ifdef CLS
+ printf("L1 cache line size (CLS)=%d\n", CLS);
diff --git a/net-analyzer/suricata/files/json.patch b/net-analyzer/suricata/files/json.patch
new file mode 100644
index 000000000000..a542f351640d
--- /dev/null
+++ b/net-analyzer/suricata/files/json.patch
@@ -0,0 +1,10 @@
+--- src/output-json.h.orig 2015-11-21 21:56:24.996289587 +0100
++++ src/output-json.h 2015-11-21 21:57:11.419622642 +0100
+@@ -28,6 +28,7 @@
+
+ #ifdef HAVE_LIBJANSSON
+
++#include <jansson.h>
+ #include "suricata-common.h"
+ #include "util-buffer.h"
+ #include "util-logopenfile.h"
diff --git a/net-analyzer/suricata/files/magic-location.patch b/net-analyzer/suricata/files/magic-location.patch
new file mode 100644
index 000000000000..02681f934b06
--- /dev/null
+++ b/net-analyzer/suricata/files/magic-location.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 8b41eb0..3cdf0e7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -182,7 +182,7 @@
+ fi
+ echo -n "installation for $host OS... "
+
+- e_magic_file="/usr/share/file/magic"
++ e_magic_file="/usr/share/misc/magic.mgc"
+ case "$host" in
+ *-*-*freebsd*)
+ LUA_PC_NAME="lua-5.1"
diff --git a/net-analyzer/suricata/metadata.xml b/net-analyzer/suricata/metadata.xml
new file mode 100644
index 000000000000..34c1b31f136c
--- /dev/null
+++ b/net-analyzer/suricata/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="af-packet">Enable AF_PACKET support</flag>
+ <flag name="control-socket">Enable unix socket</flag>
+ <flag name="cuda">Enable NVIDIA Cuda computations support</flag>
+ <flag name="luajit">Enable Luajit support</flag>
+ <flag name="nflog">Enable libnetfilter_log support</flag>
+ <flag name="nfqueue">Enable AF_PACKET support</flag>
+ <flag name="rules">Enable AF_PACKET support</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-analyzer/suricata/suricata-2.0.10.ebuild b/net-analyzer/suricata/suricata-2.0.10.ebuild
new file mode 100644
index 000000000000..40b27405908a
--- /dev/null
+++ b/net-analyzer/suricata/suricata-2.0.10.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils user
+
+DESCRIPTION="High performance Network IDS, IPS and Network Security Monitoring engine"
+HOMEPAGE="http://suricata-ids.org/"
+SRC_URI="http://www.openinfosecfoundation.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+af-packet control-socket cuda debug geoip hardened lua luajit nflog +nfqueue +rules test"
+
+DEPEND="
+ >=dev-libs/jansson-2.2
+ dev-libs/libpcre
+ dev-libs/libyaml
+ net-libs/libnet:*
+ net-libs/libnfnetlink
+ dev-libs/nspr
+ dev-libs/nss
+ net-libs/libpcap
+ sys-apps/file
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ geoip? ( dev-libs/geoip )
+ lua? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:* )
+ nflog? ( net-libs/libnetfilter_log )
+ nfqueue? ( net-libs/libnetfilter_queue )
+"
+# #446814
+# prelude? ( dev-libs/libprelude )
+# pfring? ( sys-process/numactl net-libs/pf_ring)
+# system-htp? ( >=net-analyzer/htp-0.5.5 )
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${PN}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/fortify_source-numeric.patch"
+ epatch "${FILESDIR}/magic-location.patch"
+ epatch "${FILESDIR}/json.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--localstatedir=/var/" \
+ "--disable-detection" \
+ $(use_enable af-packet) \
+ $(use_enable nfqueue) \
+ $(use_enable test coccinelle) \
+ $(use_enable test unittests) \
+ $(use_enable control-socket unix-socket)
+ )
+
+ if use cuda ; then
+ myeconfargs+=( $(use_enable cuda) )
+ fi
+ if use debug ; then
+ myeconfargs+=( $(use_enable debug) )
+ fi
+ if use geoip ; then
+ myeconfargs+=( $(use_enable geoip) )
+ fi
+ if use hardened ; then
+ myeconfargs+=( $(use_enable hardened gccprotect) )
+ fi
+ if use nflog ; then
+ myeconfargs+=( $(use_enable nflog) )
+ fi
+ # not supported yet (no pfring in portage)
+# if use pfring ; then
+# myeconfargs+=( $(use_enable pfring) )
+# fi
+ # no libprelude in portage
+# if use prelude ; then
+# myeconfargs+=( $(use_enable prelude) )
+# fi
+ # htp not added into portage yet
+# if use system-htp ; then
+# myeconfargs+=( $(use_enable system-htp non-bundled-htp) )
+# fi
+ if use lua ; then
+ myeconfargs+=( $(use_enable lua) )
+ fi
+ if use luajit ; then
+ myeconfargs+=( $(use_enable luajit) )
+ fi
+
+ LIBS+="-lrt -lnuma"
+
+ econf LIBS="${LIBS}" ${myeconfargs[@]}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto "/etc/${PN}"
+ doins {classification,reference,threshold}.config suricata.yaml
+
+ if use rules ; then
+ insinto "/etc/${PN}/rules"
+ doins rules/*.rules
+ fi
+
+ dodir "/var/lib/${PN}"
+ dodir "/var/log/${PN}"
+ fowners -R ${PN}: "/var/lib/${PN}" "/var/log/${PN}" "/etc/${PN}"
+ fperms 750 "/var/lib/${PN}" "/var/log/${PN}" "/etc/${PN}"
+} \ No newline at end of file