summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2023-09-20 19:15:13 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-10-21 11:09:02 +0200
commit0410e09398077ce8ecfed62f3d2921ff367e9d9f (patch)
treef4fee404e9652368dbb53ad9c91903f73062f6ec /net-analyzer
parentnet-misc/icingadb: drop old (diff)
downloadgentoo-0410e09398077ce8ecfed62f3d2921ff367e9d9f.tar.gz
gentoo-0410e09398077ce8ecfed62f3d2921ff367e9d9f.tar.bz2
gentoo-0410e09398077ce8ecfed62f3d2921ff367e9d9f.zip
net-analyzer/linkchecker: add 10.3.0
Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32931 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/Manifest1
-rw-r--r--net-analyzer/linkchecker/linkchecker-10.3.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-analyzer/linkchecker/Manifest b/net-analyzer/linkchecker/Manifest
index df363ab6f476..bcbda24cc7ec 100644
--- a/net-analyzer/linkchecker/Manifest
+++ b/net-analyzer/linkchecker/Manifest
@@ -1 +1,2 @@
DIST LinkChecker-10.2.1.tar.gz 545530 BLAKE2B ddbf22d9cdd04d89257b92d032cff24e4dde866b4be115f7b5b878bf2a42dd08159eef451b33ed621d747f06dffa445f4258975b932e5ae0eb8b79cfb8203549 SHA512 6410aff11e94cbf001979a85dd41e50daaa6a3577689d4256a0a5627a29253baef24ed7739dbafe91f58c0841923ac3094aa558e91f34629e3e6c008e461230a
+DIST LinkChecker-10.3.0.tar.gz 542403 BLAKE2B 24420c7479909d3d19d8fce45cfb2f5712107705a409f7d407097002ce6c6bb534a62a388b3a8d01760db7ac4200adf1d7250868dbeb41ec8cf8489a1776266b SHA512 fbcc4d10418642d6f0c0146a50294fa3d872eb98b53c49081af5d5ac644f1280694ad1ef8f82f639526ba08f6f0ed754b316567dd12c4e5e98360ccee4634d16
diff --git a/net-analyzer/linkchecker/linkchecker-10.3.0.ebuild b/net-analyzer/linkchecker/linkchecker-10.3.0.ebuild
new file mode 100644
index 000000000000..03bd5ec4bb92
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-10.3.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="sqlite?"
+DISTUTILS_USE_PEP517=hatchling
+DISTUTILS_SINGLE_IMPL=1
+
+inherit bash-completion-r1 distutils-r1 multiprocessing optfeature
+
+MY_P=LinkChecker-${PV}
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="https://github.com/linkcheck/linkchecker"
+SRC_URI="https://github.com/linkchecker/linkchecker/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sqlite"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ app-text/pdfminer[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
+ sys-devel/gettext
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}/${PN}-9.3-bash-completion.patch" )
+
+DOCS=(
+ doc/changelog.txt
+ doc/upgrading.txt
+)
+
+python_test() {
+ # Multiple warnings about unclosed test sockets with epytest
+ pytest -vra -n "$(makeopts_jobs)" || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp config/linkchecker-completion ${PN}
+}
+
+pkg_postinst() {
+ optfeature "Virus scanning" app-antivirus/clamav
+ optfeature "Check links in PDF files" app-text/pdfminer
+ optfeature "bash-completion support" dev-python/argcomplete
+}