summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2020-06-29 17:31:59 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-14 15:57:06 +0300
commit8c37d066f8c8f36ea3e762faf789034cb628f892 (patch)
tree97b7c2b20c5779d1bfb2bd550ca56a4b16da9f11 /net-analyzer/ospd-openvas
parentnet-analyzer/ospd: drop old (diff)
downloadgentoo-8c37d066f8c8f36ea3e762faf789034cb628f892.tar.gz
gentoo-8c37d066f8c8f36ea3e762faf789034cb628f892.tar.bz2
gentoo-8c37d066f8c8f36ea3e762faf789034cb628f892.zip
net-analyzer/ospd-openvas: Version bump to 1.0.1
Closes: https://bugs.gentoo.org/725896 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/ospd-openvas')
-rw-r--r--net-analyzer/ospd-openvas/Manifest1
-rw-r--r--net-analyzer/ospd-openvas/files/ospd-openvas.initd4
-rw-r--r--net-analyzer/ospd-openvas/ospd-openvas-1.0.1.ebuild46
3 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/ospd-openvas/Manifest b/net-analyzer/ospd-openvas/Manifest
index 00e7b1d401c7..adf747b4375b 100644
--- a/net-analyzer/ospd-openvas/Manifest
+++ b/net-analyzer/ospd-openvas/Manifest
@@ -1 +1,2 @@
DIST ospd-openvas-1.0.0.tar.gz 49725 BLAKE2B 230df2f572f345b9ed398e2af120a2fecee87f9f8d8d3c072ca314960f34f7329fe22b002ba0971ba6dc14cd3ca4543120653f89b3085a0f8a932fbeb6ef2682 SHA512 2b2e4f38843265a018a58b7fbd2fde0449d4f6cf3c5c1b7bec02d8390ab257020304f5be1bf2a77f7d28a04f4d1da611fc9b3066bef370dd686dfb8684fce534
+DIST ospd-openvas-1.0.1.tar.gz 50455 BLAKE2B 06a4cdcc2f51351215fffa5517cb2cae620b9b7ffded738d3c63bda11fa8572fe93e0b5fc1c8c9a1bd27cbea65641b0586c329d1d05a022e1fba79c8782d091c SHA512 bdcdb1a8bc08fc27f1a85846ad944b3764a67c153cd75ffa607f69e0c07f223aa0e0965ee081e2398d4d47fc6faf1fd6fad90e6bc724952a0679de783dd2cc87
diff --git a/net-analyzer/ospd-openvas/files/ospd-openvas.initd b/net-analyzer/ospd-openvas/files/ospd-openvas.initd
index ced28d892dcd..f8887d8b3431 100644
--- a/net-analyzer/ospd-openvas/files/ospd-openvas.initd
+++ b/net-analyzer/ospd-openvas/files/ospd-openvas.initd
@@ -15,3 +15,7 @@ depend() {
after bootmisc
need localmount redis
}
+
+start_pre() {
+ checkpath -d /var/run/ospd
+}
diff --git a/net-analyzer/ospd-openvas/ospd-openvas-1.0.1.ebuild b/net-analyzer/ospd-openvas/ospd-openvas-1.0.1.ebuild
new file mode 100644
index 000000000000..398e7aa14df2
--- /dev/null
+++ b/net-analyzer/ospd-openvas/ospd-openvas-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 systemd
+
+DESCRIPTION="This is an OSP server implementation to allow GVM to remotely control OpenVAS"
+HOMEPAGE="https://github.com/greenbone/ospd-openvas"
+SRC_URI="https://github.com/greenbone/ospd-openvas/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ acct-user/gvm
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ net-analyzer/ospd[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-analyzer/openvas-scanner-7.0.0"
+BDEPEND=""
+
+distutils_enable_tests unittest
+
+python_install() {
+ distutils-r1_python_install
+
+ insinto /etc/openvas
+ doins "${FILESDIR}"/redis.conf.example
+ doins "${FILESDIR}"/ospd.conf
+
+ fowners -R gvm:gvm /etc/openvas
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}