summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-04-01 16:22:03 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-04-01 16:23:58 -0500
commit2bc734b57f315915314865817598b717633e7785 (patch)
tree46ee054ecdac0f874a6a9ea5e35668a11ee046d4 /net-analyzer/opsgenie-lamp/opsgenie-lamp-2.5.1_p20181102.ebuild
parentapp-misc/graphlcd-base: fix media-gfx/imagemagick dependency (diff)
downloadgentoo-2bc734b57f315915314865817598b717633e7785.tar.gz
gentoo-2bc734b57f315915314865817598b717633e7785.tar.bz2
gentoo-2bc734b57f315915314865817598b717633e7785.zip
net-analyzer/opsgenie-lamp: Command line client for the opsgenie service
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-analyzer/opsgenie-lamp/opsgenie-lamp-2.5.1_p20181102.ebuild')
-rw-r--r--net-analyzer/opsgenie-lamp/opsgenie-lamp-2.5.1_p20181102.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/opsgenie-lamp/opsgenie-lamp-2.5.1_p20181102.ebuild b/net-analyzer/opsgenie-lamp/opsgenie-lamp-2.5.1_p20181102.ebuild
new file mode 100644
index 000000000000..8aba54f81df9
--- /dev/null
+++ b/net-analyzer/opsgenie-lamp/opsgenie-lamp-2.5.1_p20181102.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="command line client for the opsgenie service"
+HOMEPAGE="https://docs.opsgenie.com/docs/lamp-command-line-interface-for-opsgenie"
+HASH=062016b
+SRC_URI="https://github.com/opsgenie/${PN}/archive/${HASH}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.gz"
+
+# I followed the following steps to create the vendor tarball:
+#
+# git clone https://github.com/opsgenie/opsgenie-lamp
+# cd opsgenie-lamp
+# go mod init # creates go.mod and go.sum
+# go mod vendor # updates go.mod/sum and adds vendor directory
+# mv -i go.mod go.sum vendor
+# tar cf ${P}.tar vendor
+# gzip ${P}.tar
+#
+# Upstream doesn't tag releases, but the most recent version number is
+# in the sources, see the lampVersion variable.
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-lang/go:="
+
+RESTRICT="strip"
+
+src_prepare() {
+ mv ../${P}-vendor vendor || die "mv failed"
+ mv vendor/go.mod vendor/go.sum . || die "mv failed"
+ default
+}
+
+src_compile() {
+ GOCACHE="${T}"/go-cache go build -mod vendor || die "build failed"
+}
+
+src_install() {
+ newbin ${PN} lamp
+dodoc conf/lamp.conf
+ einstalldocs
+}