summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-04-14 07:32:21 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-04-14 07:39:59 -0400
commitb992d10c122175a7a90901a0b1c5450aaa4c89f6 (patch)
tree5b491b0959252b11eea0703c58b731fc86ce7ed6 /net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r4.ebuild
parentapp-backup/untangle-https-backup: support python 3.12, drop 3.9 (diff)
downloadgentoo-b992d10c122175a7a90901a0b1c5450aaa4c89f6.tar.gz
gentoo-b992d10c122175a7a90901a0b1c5450aaa4c89f6.tar.bz2
gentoo-b992d10c122175a7a90901a0b1c5450aaa4c89f6.zip
net-analyzer/nagios-icinga-openvpn: support python 3.12, drop 3.9
Closes: https://bugs.gentoo.org/929683 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r4.ebuild')
-rw-r--r--net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r4.ebuild b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r4.ebuild
new file mode 100644
index 000000000000..f2cd71d9e794
--- /dev/null
+++ b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 python3_11 python3_12 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+MY_PN="check_openvpn"
+DESCRIPTION="A Nagios plugin to check whether an OpenVPN server is alive"
+HOMEPAGE="https://github.com/liquidat/nagios-icinga-openvpn"
+SRC_URI="https://github.com/liquidat/nagios-icinga-openvpn/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}