summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-13 05:54:25 +0100
committerSam James <sam@gentoo.org>2022-04-13 05:55:01 +0100
commit00d854ad87a75f20d241173633ba730a27736ec4 (patch)
tree58b26a4c2b52bcb559148a09f50bde5c9f77106a /net-analyzer/hydra
parentapp-shells/nushell: add 0.61.0 (diff)
downloadgentoo-00d854ad87a75f20d241173633ba730a27736ec4.tar.gz
gentoo-00d854ad87a75f20d241173633ba730a27736ec4.tar.bz2
gentoo-00d854ad87a75f20d241173633ba730a27736ec4.zip
net-analyzer/hydra: GTK 3 port is broken
It doesn't seem to actually build against 3, configure wasn't regenerated properly. Bug: https://bugs.gentoo.org/838031 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/hydra')
-rw-r--r--net-analyzer/hydra/hydra-9.3-r1.ebuild (renamed from net-analyzer/hydra/hydra-9.3.ebuild)10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-analyzer/hydra/hydra-9.3.ebuild b/net-analyzer/hydra/hydra-9.3-r1.ebuild
index aa7d807e29b8..d149fdce2dde 100644
--- a/net-analyzer/hydra/hydra-9.3.ebuild
+++ b/net-analyzer/hydra/hydra-9.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Parallelized network login hacker"
HOMEPAGE="https://github.com/vanhauser-thc/thc-hydra"
@@ -21,7 +21,7 @@ RDEPEND="
dev-libs/atk
dev-libs/glib:2
x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
+ x11-libs/gtk+:2
)
firebird? ( dev-db/firebird )
gcrypt? ( dev-libs/libgcrypt )
@@ -58,6 +58,12 @@ src_prepare() {
-e '/^OPTS/{s|=|+=|;s| -O3||}' \
-e '/ -o /s:$(OPTS):& $(LDFLAGS):g' \
Makefile.am || die
+
+ # Needed to get GTK+ 3 change in configure.in (.in got updated, but
+ # configure not regen'd.)
+ #cd hydra-gtk || die
+ #sed -i -e 's:AC_INIT(configure.in):AC_INIT(configure.ac):' configure.in || die
+ #eautoreconf
}
src_configure() {