summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNinpo <ninpo@qap.la>2023-07-05 22:17:40 +0100
committerSam James <sam@gentoo.org>2023-07-06 01:05:28 +0100
commit86208fb4b10d1d30908d7e13db86910420017473 (patch)
tree4c943dd7d0f00cc16077fefa26f1fb90dbdd571a /media-video
parentmedia-libs/libopenshot: add 0.3.2 (diff)
downloadgentoo-86208fb4b10d1d30908d7e13db86910420017473.tar.gz
gentoo-86208fb4b10d1d30908d7e13db86910420017473.tar.bz2
gentoo-86208fb4b10d1d30908d7e13db86910420017473.zip
media-video/openshot: add 3.1.1
Closes: https://bugs.gentoo.org/876397 Closes: https://bugs.gentoo.org/887437 Closes: https://bugs.gentoo.org/909641 Signed-off-by: Ninpo <ninpo@qap.la> Closes: https://github.com/gentoo/gentoo/pull/31764 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/openshot/Manifest1
-rw-r--r--media-video/openshot/openshot-3.1.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-video/openshot/Manifest b/media-video/openshot/Manifest
index c7d5944f54b6..231590e5be23 100644
--- a/media-video/openshot/Manifest
+++ b/media-video/openshot/Manifest
@@ -1 +1,2 @@
DIST openshot-2.6.1.tar.gz 68566443 BLAKE2B b3a163983bdb811103e5d9307beeb38938719747f743dd58520a0166c08eb11f4592d47bf24224062f9db323a66a2f353eb22f087982b929d60a519cd2c40789 SHA512 9e2d1eae5d72ec2deab914e464dac0d84a864ba2ca63104fad57c90fc907764d5683149fb8136d50030cae993cef9a977e995b0783868988de4668e71a3a5ee2
+DIST openshot-3.1.1.tar.gz 95843738 BLAKE2B 4059fe12b064692070278366f787789866dcbe39414d10217fb62b671dda98ebb6d2f76b8e1cfe2284a647e3d7ebc460b620ba0756a4542f5b26e7ef669e9b3e SHA512 4e5a42825abf8e3862957039169905a6f03872d81de454f52a57ace2e636e91b2f4e87ae603bf9669baa7d1bbbd6c0213efd0c72e23f2b209ba266af2fbe380f
diff --git a/media-video/openshot/openshot-3.1.1.ebuild b/media-video/openshot/openshot-3.1.1.ebuild
new file mode 100644
index 000000000000..ed54b7e4cd36
--- /dev/null
+++ b/media-video/openshot/openshot-3.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg
+
+MY_PN="${PN}-qt"
+
+DESCRIPTION="Award-winning free and open-source video editor"
+HOMEPAGE="https://openshot.org/"
+SRC_URI="https://github.com/OpenShot/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,svg,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ >=media-libs/libopenshot-0.3.2:0=[python,${PYTHON_SINGLE_USEDEP}]"
+DEPEND=""
+BDEPEND="$(python_gen_cond_dep '
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ')"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # prevent setup.py from trying to update MIME databases
+ sed -i 's/^ROOT =.*/ROOT = False/' setup.py || die
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" src/tests/query_tests.py -v --platform minimal || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}