summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChaosEngine <andrzej.pauli@gmail.com>2020-12-18 19:37:24 +0100
committerSam James <sam@gentoo.org>2021-08-14 00:28:08 +0100
commit756b6abf8f45094c7b649fd00878ed7d80db7905 (patch)
treedafeec992d77250acefc11ce64ef323de9d8d7a0 /media-video/mjpg-streamer
parentmedia-video/mjpg-streamer: misc fixes (diff)
downloadgentoo-756b6abf8f45094c7b649fd00878ed7d80db7905.tar.gz
gentoo-756b6abf8f45094c7b649fd00878ed7d80db7905.tar.bz2
gentoo-756b6abf8f45094c7b649fd00878ed7d80db7905.zip
media-video/mjpg-streamer: Raspberry Pi camera support via the input_raspicam plugin
Closes: https://github.com/gentoo/gentoo/pull/16015 Package-Manager: Portage-2.3.99, Repoman 2.3.22 Signed-off-by: Andrzej Pauli <andrzej.pauli@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/mjpg-streamer')
-rw-r--r--media-video/mjpg-streamer/metadata.xml1
-rw-r--r--media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild7
2 files changed, 6 insertions, 2 deletions
diff --git a/media-video/mjpg-streamer/metadata.xml b/media-video/mjpg-streamer/metadata.xml
index 3df394f71ec1..8e9f536d7b31 100644
--- a/media-video/mjpg-streamer/metadata.xml
+++ b/media-video/mjpg-streamer/metadata.xml
@@ -26,6 +26,7 @@
compatible camera</flag>
<flag name="input-http">Plugin that takes http-input</flag>
<flag name="input-ptp2">Plugin that sends video stream from PTP2 compatible camera</flag>
+ <flag name="input-raspicam">Raspberry Pi camera support via the input_raspicam plugin</flag>
<flag name="output-file">Plugin that saves received content under given
location</flag>
<flag name="output-udp">Plugin receiving content over UDP and storing to
diff --git a/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild b/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild
index 231db6a85a23..6e33ef5d6e9a 100644
--- a/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild
+++ b/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild
@@ -14,10 +14,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-INPUT_PLUGINS="input-testpicture input-control input-file input-uvc input-http input-ptp2"
+INPUT_PLUGINS="input-testpicture input-control input-file input-uvc input-http input-ptp2 input-raspicam"
OUTPUT_PLUGINS="output-file output-udp output-http output-autofocus output-rtsp output-viewer output-zmqserver"
IUSE_PLUGINS="${INPUT_PLUGINS} ${OUTPUT_PLUGINS}"
-IUSE="input-testpicture input-control +input-file input-uvc input-http input-ptp2
+IUSE="input-testpicture input-control +input-file input-uvc input-http input-ptp2 input-raspicam
output-file output-udp +output-http output-autofocus output-rtsp output-viewer output-zmqserver
www http-management wxp-compat"
REQUIRED_USE="|| ( ${INPUT_PLUGINS} )
@@ -26,6 +26,9 @@ REQUIRED_USE="|| ( ${INPUT_PLUGINS} )
RDEPEND="virtual/jpeg
input-uvc? ( media-libs/libv4l acct-group/video )
input-ptp2? ( media-libs/libgphoto2 )
+ input-raspicam? (
+ || ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin )
+ )
output-zmqserver? (
dev-libs/protobuf-c
net-libs/zeromq