summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-28 13:50:53 +0100
committerMatthew Thode <prometheanfire@gentoo.org>2022-01-05 10:42:35 -0600
commitee5a8dacc289e957c9ef6f1a0cb224b4ef1b07dc (patch)
treeb401d462dd0bb9edc62a2aeddfc30b5ecf3cf856 /media-sound
parentmedia-sound/spotify: rework systray support (diff)
downloadgentoo-ee5a8dacc289e957c9ef6f1a0cb224b4ef1b07dc.tar.gz
gentoo-ee5a8dacc289e957c9ef6f1a0cb224b4ef1b07dc.tar.bz2
gentoo-ee5a8dacc289e957c9ef6f1a0cb224b4ef1b07dc.zip
media-sound/spotify-tray: drop desktop file
launching is now handled in spotify launch script from spotify ebuild Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild (renamed from media-sound/spotify-tray/spotify-tray-1.3.2.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-sound/spotify-tray/spotify-tray-1.3.2.ebuild b/media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild
index 5de180e44e4e..dc3be566510a 100644
--- a/media-sound/spotify-tray/spotify-tray-1.3.2.ebuild
+++ b/media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools xdg
@@ -29,3 +29,9 @@ src_prepare() {
sed -i -e 's/Icon=spotify/Icon=spotify-client/g' spotify-tray.desktop.in || die
eautoreconf
}
+
+src_install() {
+ default
+ # remove desktop file, launching is handled in spotify ebuild
+ rm "${ED}/usr/share/applications/spotify-tray.desktop" || die
+}