summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-18 02:13:25 +0100
committerSam James <sam@gentoo.org>2022-09-18 02:13:25 +0100
commitc62644e62856e96f2a07c4d8355a4f37ab2dc0ac (patch)
treeb2edcf18bda5694c4c6e3e6cfc19c69451faad9a /media-sound
parentdev-ml/opam: Stabilize 2.1.2-r1 x86, #859508 (diff)
downloadgentoo-c62644e62856e96f2a07c4d8355a4f37ab2dc0ac.tar.gz
gentoo-c62644e62856e96f2a07c4d8355a4f37ab2dc0ac.tar.bz2
gentoo-c62644e62856e96f2a07c4d8355a4f37ab2dc0ac.zip
media-sound/mpck: EAPI 8, fix implicit func. declarations
Closes: https://bugs.gentoo.org/870964 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpck/files/mpck-0.15-implicit-func-decl.patch10
-rw-r--r--media-sound/mpck/mpck-0.15-r1.ebuild (renamed from media-sound/mpck/mpck-0.15.ebuild)11
2 files changed, 17 insertions, 4 deletions
diff --git a/media-sound/mpck/files/mpck-0.15-implicit-func-decl.patch b/media-sound/mpck/files/mpck-0.15-implicit-func-decl.patch
new file mode 100644
index 000000000000..2c30d369599c
--- /dev/null
+++ b/media-sound/mpck/files/mpck-0.15-implicit-func-decl.patch
@@ -0,0 +1,10 @@
+--- a/mpck/file.c
++++ b/mpck/file.c
+@@ -27,6 +27,7 @@
+ #include "file.h"
+ #include "mp3errors.h"
+ #include "options.h"
++#include "print.h"
+
+ #ifdef HAVE_STDLIB_H
+ #include <stdlib.h>
diff --git a/media-sound/mpck/mpck-0.15.ebuild b/media-sound/mpck/mpck-0.15-r1.ebuild
index 1df48af46667..dfc0a2940a94 100644
--- a/media-sound/mpck/mpck-0.15.ebuild
+++ b/media-sound/mpck/mpck-0.15-r1.ebuild
@@ -1,18 +1,21 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_P=checkmate-${PV}
DESCRIPTION="Checks MP3s for errors"
HOMEPAGE="http://mpck.linuxonly.nl/"
SRC_URI="http://checkmate.linuxonly.nl/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-S="${WORKDIR}/${MY_P}"
-
DOCS=( ABOUT_FIXING AUTHORS ChangeLog HISTORY NEWS README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15-implicit-func-decl.patch
+)