summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2019-08-04 18:42:21 +0200
committerAaron Bauman <bman@gentoo.org>2019-08-04 19:43:03 -0400
commit260a03fc7a3a127028a02dffaa621ef4071d64a5 (patch)
treed9b00f1a04772599accc297e10173b0bbbf32b12 /media-sound/whipper
parentapp-misc/pip3line: package removal (diff)
downloadgentoo-260a03fc7a3a127028a02dffaa621ef4071d64a5.tar.gz
gentoo-260a03fc7a3a127028a02dffaa621ef4071d64a5.tar.bz2
gentoo-260a03fc7a3a127028a02dffaa621ef4071d64a5.zip
media-sound/whipper: remove version 0.7.3-r0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/12619 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'media-sound/whipper')
-rw-r--r--media-sound/whipper/whipper-0.7.3.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/media-sound/whipper/whipper-0.7.3.ebuild b/media-sound/whipper/whipper-0.7.3.ebuild
deleted file mode 100644
index f7f2f40ca587..000000000000
--- a/media-sound/whipper/whipper-0.7.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python CD-DA ripper preferring accuracy over speed (forked from morituri)"
-HOMEPAGE="https://github.com/whipper-team/whipper"
-SRC_URI="https://github.com/whipper-team/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- media-libs/libsndfile
- test? ( dev-python/twisted[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- app-cdr/cdrdao
- dev-libs/gobject-introspection[${PYTHON_USEDEP}]
- >=dev-libs/libcdio-paranoia-0.94_p2
- dev-python/pycdio[${PYTHON_USEDEP}]
- dev-python/pygobject:2=[${PYTHON_USEDEP}]
- dev-python/python-musicbrainz-ngs[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- media-libs/flac
- media-libs/libsndfile
- media-libs/mutagen[${PYTHON_USEDEP}]
- media-sound/sox[flac]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.7.0-cdparanoia-name-fix.patch"
- "${FILESDIR}/${PN}-0.7.0-src-Makefile-respect-CFLAGS.patch"
-)
-
-src_prepare() {
- # accurip test totally depends on network access
- rm "${PN}"/test/test_common_accurip.py || die
-
- distutils-r1_src_prepare
-}
-
-src_compile() {
- distutils-r1_src_compile
- emake -C src CC="$(tc-getCC)"
-}
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
-}
-
-src_install() {
- distutils-r1_src_install
- emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" -C src install
-}