summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/solfege
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/solfege')
-rw-r--r--media-sound/solfege/Manifest1
-rw-r--r--media-sound/solfege/metadata.xml8
-rw-r--r--media-sound/solfege/solfege-3.22.2.ebuild57
3 files changed, 66 insertions, 0 deletions
diff --git a/media-sound/solfege/Manifest b/media-sound/solfege/Manifest
new file mode 100644
index 000000000000..b0e3fd5b7709
--- /dev/null
+++ b/media-sound/solfege/Manifest
@@ -0,0 +1 @@
+DIST solfege-3.22.2.tar.gz 6890977 SHA256 e46a0960c83e4998d9dcf7bb07b8269e03fc81fab6c4485f8112c5a3e6488fe4 SHA512 7767d5747b324558fb5ebc82767fd592636acbea78d083992ae100a6b288bb3cc233745e9f12c66f5059a8531a85be2ec82aa856d9251206c737a090b1d42a26 WHIRLPOOL d506661fdff385484c63006a0ab1f92ec787d435e0f56d77a4a57e5cb4636995b1fe49eae5fb982731677f0716cb8fa0f09d2c9913a3ee68768d8f4bc0d7fc67
diff --git a/media-sound/solfege/metadata.xml b/media-sound/solfege/metadata.xml
new file mode 100644
index 000000000000..cc9b6dc7e0d3
--- /dev/null
+++ b/media-sound/solfege/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">solfege</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/solfege/solfege-3.22.2.ebuild b/media-sound/solfege/solfege-3.22.2.ebuild
new file mode 100644
index 000000000000..380b72a570b8
--- /dev/null
+++ b/media-sound/solfege/solfege-3.22.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1
+
+DESCRIPTION="GNU Solfege is a program written to help you practice ear training"
+HOMEPAGE="http://www.solfege.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="alsa oss"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/pygtk-2.12
+ gnome-base/librsvg
+ alsa? ( dev-python/pyalsa )
+ !oss? ( media-sound/timidity++ )"
+DEPEND="${PYTHON_DEPS}
+ dev-lang/swig
+ sys-devel/gettext
+ sys-apps/texinfo
+ virtual/pkgconfig
+ dev-libs/libxslt
+ app-text/txt2man
+ >=app-text/docbook-xsl-stylesheets-1.60"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/^CFLAGS/s:-I/usr/src/linux/include::' \
+ solfege/soundcard/Makefile || die
+}
+
+src_configure() {
+ local xslloc=$( xmlcatalog /etc/xml/catalog http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl | sed 's@file://@@' )
+
+ econf \
+ --enable-docbook-stylesheet=${xslloc} \
+ $(use_enable oss oss-sound)
+}
+
+src_compile() {
+ emake skipmanual=yes
+}
+
+src_install() {
+ emake DESTDIR="${ED}" nopycompile=YES skipmanual=yes install
+ dodoc AUTHORS *hange*og FAQ README
+}