summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-12-24 11:46:22 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-12-24 11:46:22 +0100
commite628e4a0b3660c3caba67d09eccc77331609018f (patch)
tree362b5c84a467183e3dde8214ec31de8d4d56dd97 /media-sound/sidplayfp
parentmedia-sound/abcmidi: bump to 2023.12.23 (diff)
downloadgentoo-e628e4a0b3660c3caba67d09eccc77331609018f.tar.gz
gentoo-e628e4a0b3660c3caba67d09eccc77331609018f.tar.bz2
gentoo-e628e4a0b3660c3caba67d09eccc77331609018f.zip
media-sound/sidplayfp: bump to 2.5.1
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/sidplayfp')
-rw-r--r--media-sound/sidplayfp/Manifest1
-rw-r--r--media-sound/sidplayfp/sidplayfp-2.5.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/sidplayfp/Manifest b/media-sound/sidplayfp/Manifest
index 20770ea6bbd3..51620928882c 100644
--- a/media-sound/sidplayfp/Manifest
+++ b/media-sound/sidplayfp/Manifest
@@ -1 +1,2 @@
DIST sidplayfp-2.5.0.tar.gz 249111 BLAKE2B 6ac126ee1f26e2dafe649d1bc64fd053ac6762277996dcbc6704dbda788bd2b3d3d2810aba48a8d9fd62ae92f70773cc93a657198c414327ea18fc074da35c96 SHA512 271d1ef216ace5294084997dc902f74411679b24dd3426248c70004468c0525077f0d6cf187f24715d1b6465abf82236b328904b7c06d4e0f87e159594be6427
+DIST sidplayfp-2.5.1.tar.gz 244863 BLAKE2B 463a8716f0a1f310780aec559ebb1128749cc0cc97da254d422552859450cf1e721510b1706a59181e2ca1bf1575a68cfec96f688b164c289ae06a1b045b46dd SHA512 f7c13171d163cf49a2e2b1c485255bd80a3ebdd157343489ac5915e2190c325da327dd1c9413fc9daf6c7d8183c01473d2fc35ca38bfe516515780c464187199
diff --git a/media-sound/sidplayfp/sidplayfp-2.5.1.ebuild b/media-sound/sidplayfp/sidplayfp-2.5.1.ebuild
new file mode 100644
index 000000000000..f1866978a2ef
--- /dev/null
+++ b/media-sound/sidplayfp/sidplayfp-2.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa oss pulseaudio"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ media-libs/libsidplayfp
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-libs/libpulse )"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )"
+
+DOCS=( AUTHORS README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.4-musl-limits.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use alsa; then
+ sed -i -e 's:alsa >= 1.0:dIsAbLe&:' configure || die
+ fi
+
+ if ! use pulseaudio; then
+ sed -i -e 's:libpulse-simple >= 1.0:dIsAbLe&:' configure || die
+ fi
+}
+
+src_configure() {
+ export ac_cv_header_linux_soundcard_h=$(usex oss)
+
+ econf
+}