summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-launcher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-launcher')
-rw-r--r--media-plugins/vdr-launcher/Manifest1
-rw-r--r--media-plugins/vdr-launcher/files/confd11
-rw-r--r--media-plugins/vdr-launcher/files/rc-addon.sh11
-rw-r--r--media-plugins/vdr-launcher/metadata.xml12
-rw-r--r--media-plugins/vdr-launcher/vdr-launcher-0.0.4.ebuild19
5 files changed, 54 insertions, 0 deletions
diff --git a/media-plugins/vdr-launcher/Manifest b/media-plugins/vdr-launcher/Manifest
new file mode 100644
index 000000000000..89dd422b2ead
--- /dev/null
+++ b/media-plugins/vdr-launcher/Manifest
@@ -0,0 +1 @@
+DIST vdr-launcher-0.0.4.tgz 15864 SHA256 39ba03ba9191d91ca9ad128ba6d19dd8e0098d2b5c7307627355e4895a3f71af SHA512 1c10b3cb9cc7e4055d087e288f313e9b916e78d81ec604169f48db4b6575d8bba1d8ae54734b73e4e445ce2f4fb5ae8c69edd9f3a944bec1c8cfe9500673ebdc WHIRLPOOL 9267c20e89da6c07e9f68c7825bb6259382de8409bc75a08c97ecd213be9b117d5a0acb43773bde6d2f51c7fc07956787d81d5a0b47b834313714eecfc8b8079
diff --git a/media-plugins/vdr-launcher/files/confd b/media-plugins/vdr-launcher/files/confd
new file mode 100644
index 000000000000..759094fde0eb
--- /dev/null
+++ b/media-plugins/vdr-launcher/files/confd
@@ -0,0 +1,11 @@
+# /etc/conf.d/vdr.launcher:
+# $Id$
+
+# config file for vdr plugin launcher
+
+# If you want to disable some plugins in the laucher plugin,
+# please specify them here
+# allowed values: list of plugin names
+# default value: do not exclude any plugin
+#VDR_LAUNCHER_EXCLUDE="plugin1 plugin2"
+
diff --git a/media-plugins/vdr-launcher/files/rc-addon.sh b/media-plugins/vdr-launcher/files/rc-addon.sh
new file mode 100644
index 000000000000..9b52741e463f
--- /dev/null
+++ b/media-plugins/vdr-launcher/files/rc-addon.sh
@@ -0,0 +1,11 @@
+# $Id$
+#
+# rc-addon plugin-startup-skript for vdr-launcher
+#
+
+plugin_pre_vdr_start() {
+ local p
+ for p in ${VDR_LAUNCHER_EXCLUDE}; do
+ add_plugin_param "-x ${p}"
+ done
+}
diff --git a/media-plugins/vdr-launcher/metadata.xml b/media-plugins/vdr-launcher/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-launcher/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-launcher/vdr-launcher-0.0.4.ebuild b/media-plugins/vdr-launcher/vdr-launcher-0.0.4.ebuild
new file mode 100644
index 000000000000..26d10539cc9b
--- /dev/null
+++ b/media-plugins/vdr-launcher/vdr-launcher-0.0.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: launch other plugins - even when their menu-entry is hidden"
+HOMEPAGE="http://people.freenet.de/cwieninger/html/vdr-launcher.html"
+SRC_URI="http://winni.vdr-developer.org/launcher/downloads/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.7"
+RDEPEND="${DEPEND}"