summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-10 07:51:42 +0100
committerSam James <sam@gentoo.org>2023-07-10 07:51:42 +0100
commit5b868f7c8e48151d4beff2044ae3d5318f7bddc5 (patch)
treea718bb2301146be7e568a406156e61b02c9d9229 /media-libs
parentapp-text/qpdf: add 11.5.0 (diff)
downloadgentoo-5b868f7c8e48151d4beff2044ae3d5318f7bddc5.tar.gz
gentoo-5b868f7c8e48151d4beff2044ae3d5318f7bddc5.tar.bz2
gentoo-5b868f7c8e48151d4beff2044ae3d5318f7bddc5.zip
media-libs/harfbuzz: backport -Wcast-align fix for arm
While it's supposed to error out on ARM, it was still wrong before. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/files/harfbuzz-8.0.0-arm-cast-align.patch31
-rw-r--r--media-libs/harfbuzz/harfbuzz-8.0.0-r1.ebuild (renamed from media-libs/harfbuzz/harfbuzz-8.0.0.ebuild)4
2 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/files/harfbuzz-8.0.0-arm-cast-align.patch b/media-libs/harfbuzz/files/harfbuzz-8.0.0-arm-cast-align.patch
new file mode 100644
index 000000000000..c83336ce3fd0
--- /dev/null
+++ b/media-libs/harfbuzz/files/harfbuzz-8.0.0-arm-cast-align.patch
@@ -0,0 +1,31 @@
+https://github.com/harfbuzz/harfbuzz/commit/db3aeeb547c1a2cad46ea03e162593d22f700cb4
+
+From db3aeeb547c1a2cad46ea03e162593d22f700cb4 Mon Sep 17 00:00:00 2001
+From: Behdad Esfahbod <behdad@behdad.org>
+Date: Sun, 9 Jul 2023 12:32:49 -0600
+Subject: [PATCH] [subset] Fix cast-align issue
+
+Fixes https://github.com/harfbuzz/harfbuzz/issues/4316
+--- a/src/hb-serialize.hh
++++ b/src/hb-serialize.hh
+@@ -266,7 +266,7 @@ struct hb_serialize_context_t
+ propagate_error (std::forward<Ts> (os)...); }
+
+ /* To be called around main operation. */
+- template <typename Type>
++ template <typename Type=char>
+ __attribute__((returns_nonnull))
+ Type *start_serialize ()
+ {
+--- a/src/hb-subset.cc
++++ b/src/hb-subset.cc
+@@ -273,7 +273,7 @@ _try_subset (const TableType *table,
+ hb_vector_t<char>* buf,
+ hb_subset_context_t* c /* OUT */)
+ {
+- c->serializer->start_serialize<TableType> ();
++ c->serializer->start_serialize ();
+ if (c->serializer->in_error ()) return false;
+
+ bool needed = table->subset (c);
+
diff --git a/media-libs/harfbuzz/harfbuzz-8.0.0.ebuild b/media-libs/harfbuzz/harfbuzz-8.0.0-r1.ebuild
index c114ab1668f9..96c18d1d4c46 100644
--- a/media-libs/harfbuzz/harfbuzz-8.0.0.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-8.0.0-r1.ebuild
@@ -46,6 +46,10 @@ BDEPEND="
introspection? ( dev-util/glib-utils )
"
+PATCHES=(
+ "${FILESDIR}"/${P}-arm-cast-align.patch
+)
+
src_prepare() {
default