summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-31 17:23:26 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-08-19 15:57:52 +0300
commit9e84772f1984bd5c52aae9e7c06fc2fea3aca82c (patch)
treed95c91ee33d47513a44d43f8cdb28ce915f6a31e /media-libs/libsfml/libsfml-2.6.0.ebuild
parentapp-text/mecab: Fix no template named binary_function (diff)
downloadgentoo-9e84772f1984bd5c52aae9e7c06fc2fea3aca82c.tar.gz
gentoo-9e84772f1984bd5c52aae9e7c06fc2fea3aca82c.tar.bz2
gentoo-9e84772f1984bd5c52aae9e7c06fc2fea3aca82c.zip
media-libs/libsfml: add 2.6.0
Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32122 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/libsfml/libsfml-2.6.0.ebuild')
-rw-r--r--media-libs/libsfml/libsfml-2.6.0.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/media-libs/libsfml/libsfml-2.6.0.ebuild b/media-libs/libsfml/libsfml-2.6.0.ebuild
new file mode 100644
index 000000000000..5f453650bf72
--- /dev/null
+++ b/media-libs/libsfml/libsfml-2.6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Simple and Fast Multimedia Library (SFML)"
+HOMEPAGE="https://www.sfml-dev.org/ https://github.com/SFML/SFML"
+SRC_URI="https://github.com/SFML/SFML/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="
+ media-libs/flac:=
+ media-libs/freetype:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/xcb-util-image
+ kernel_linux? ( virtual/libudev:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( changelog.md readme.md )
+
+S="${WORKDIR}/SFML-${PV}"
+
+src_prepare() {
+ sed -i "s:DESTINATION .*:DESTINATION /usr/share/doc/${PF}:" \
+ doc/CMakeLists.txt || die
+
+ find examples -name CMakeLists.txt -delete || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSFML_BUILD_DOC=$(usex doc)
+ -DSFML_INSTALL_PKGCONFIG_FILES=TRUE
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /usr/share/cmake/Modules
+ doins cmake/SFMLConfig.cmake.in
+ doins cmake/SFMLConfigDependencies.cmake.in
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}