summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2025-01-05 13:54:28 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2025-01-05 13:54:38 +0100
commit3427a8e29fa37c461866d293f31f662276c8d1d3 (patch)
treeb2f328f062226001483d1dfaca57b5bbb74ece68 /media-libs/libopenraw
parentdev-python/pytest-httpx: keyword 0.35.0 for ~loong (diff)
downloadgentoo-3427a8e29fa37c461866d293f31f662276c8d1d3.tar.gz
gentoo-3427a8e29fa37c461866d293f31f662276c8d1d3.tar.bz2
gentoo-3427a8e29fa37c461866d293f31f662276c8d1d3.zip
media-libs/libopenraw: fixed boost detection
Closes: https://bugs.gentoo.org/919349 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/libopenraw')
-rw-r--r--media-libs/libopenraw/files/libopenraw-0.3.7-fix-boost-detection.patch12
-rw-r--r--media-libs/libopenraw/libopenraw-0.3.7-r1.ebuild3
2 files changed, 14 insertions, 1 deletions
diff --git a/media-libs/libopenraw/files/libopenraw-0.3.7-fix-boost-detection.patch b/media-libs/libopenraw/files/libopenraw-0.3.7-fix-boost-detection.patch
new file mode 100644
index 000000000000..1ca47ea5cc90
--- /dev/null
+++ b/media-libs/libopenraw/files/libopenraw-0.3.7-fix-boost-detection.patch
@@ -0,0 +1,12 @@
+--- a/m4/boost.m4
++++ b/m4/boost.m4
+@@ -229,6 +229,9 @@ AC_LANG_POP([C++])dnl
+ [#include <boost/version.hpp>
+ boost-lib-version = BOOST_LIB_VERSION],
+ [boost_cv_lib_version=`cat conftest.i`])])
++ if test x"$boost_cv_lib_version" = x; then
++ boost_cv_lib_version=$(grep "#define BOOST_LIB_VERSION" /usr/include/boost/version.hpp | sed 's/.*"\(.*\)".*/\1/')
++ fi
+ # e.g. "134" for 1_34_1 or "135" for 1_35
+ boost_major_version=`echo "$boost_cv_lib_version" | sed 's/_//;s/_.*//'`
+ case $boost_major_version in #(
diff --git a/media-libs/libopenraw/libopenraw-0.3.7-r1.ebuild b/media-libs/libopenraw/libopenraw-0.3.7-r1.ebuild
index 4825810f5604..9d8e94968f46 100644
--- a/media-libs/libopenraw/libopenraw-0.3.7-r1.ebuild
+++ b/media-libs/libopenraw/libopenraw-0.3.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -39,6 +39,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.3.7-slibtool.patch #913723
+ "${FILESDIR}"/${PN}-0.3.7-fix-boost-detection.patch #919349
)
src_prepare() {