summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 14:55:47 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 14:56:47 +0200
commit2ba0b24b5ffeb56d9fc2b69834745688f61497cc (patch)
treec7858bd5a6d9a0a2e4b6badd8d2fe2d42d974847 /media-gfx
parentmail-client/thunderbird-bin: add 91.10.0, drop 91.9.1 (diff)
downloadgentoo-2ba0b24b5ffeb56d9fc2b69834745688f61497cc.tar.gz
gentoo-2ba0b24b5ffeb56d9fc2b69834745688f61497cc.tar.bz2
gentoo-2ba0b24b5ffeb56d9fc2b69834745688f61497cc.zip
media-gfx/libredwg: enable py3.11, strip .la files if not static-libs
Closes: https://bugs.gentoo.org/847397 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/libredwg/libredwg-0.12.5-r1.ebuild (renamed from media-gfx/libredwg/libredwg-0.12.5.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-gfx/libredwg/libredwg-0.12.5.ebuild b/media-gfx/libredwg/libredwg-0.12.5-r1.ebuild
index 8f14bdef8e11..a1d3d185df43 100644
--- a/media-gfx/libredwg/libredwg-0.12.5.ebuild
+++ b/media-gfx/libredwg/libredwg-0.12.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
DOCS_BUILDER="doxygen"
# File is hardcoded to be run from ../ so we use this instead of DOCS_DIR
DOCS_CONFIG_NAME="doc/Doxyfile"
@@ -103,4 +103,9 @@ src_install() {
perl_set_version
default
use python && python_optimize
+ # remove .la files if static-libs disabled
+ if ! use static-libs; then
+ rm "${ED}/usr/$(get_libdir)/libredwg.la" || die
+ use python && rm "${D}/$(python_get_sitedir)/_LibreDWG.la" || die
+ fi
}