summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-06 19:27:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-06 19:27:47 +0100
commitc6320bb13dc48f0969cc893f4406c7b892b819c3 (patch)
treea01a01e4f3df86e3ea7d5a862ff5d0e8fc1d7f95 /kde-plasma/plasma-nm
parentnet-misc/dhcpcd: Remove more unstable versions (diff)
downloadgentoo-c6320bb13dc48f0969cc893f4406c7b892b819c3.tar.gz
gentoo-c6320bb13dc48f0969cc893f4406c7b892b819c3.tar.bz2
gentoo-c6320bb13dc48f0969cc893f4406c7b892b819c3.zip
kde-plasma: Add KDE Plasma 5.12.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.12.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 4a2f894317ec..152679b55f79 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1 +1,2 @@
DIST plasma-nm-5.11.5.tar.xz 718500 BLAKE2B bdd9520cfa3a305f7f2c271fdfc9678b43ed46e160ff7c7485a963889b32e60f56408bcc39b4fce81e570ce194410730a628bb2eb96afcfba8704b787d90c05a SHA512 6bc42e9b385fff03d994d66fb2088ce22b2766588c655466e4e26a0b57f1533c142ce7712c9182d9003368f30086333ea9670bac54b9b797e58a968f8bfc3512
+DIST plasma-nm-5.12.0.tar.xz 701352 BLAKE2B b1c3f620b126f7f8edf7dbeb785c5195bd4c98dae78eca9bbc1f0d05de7f0bec5bcf935ab9a62b0a2579495dc2c07563c696924610052e98b0318205d6ef6e61 SHA512 08b6cc42eee0e5a4314884be34e7108bf6bc96fe5916cd52f85cb9913d3e488cb15b7cb680d87ab8257a54ebb16ea6f3f54e31b927e18e86024c43c1f14de9c0
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.12.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.12.0.ebuild
new file mode 100644
index 000000000000..3d76b41d85c4
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.12.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5]
+ >=net-misc/networkmanager-0.9.10.0[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/plasma-nm:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package modemmanager ModemManager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ einfo "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ einfo "However, the networkmanagement KCM can be called from either systemsettings"
+ einfo "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}