summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-02 21:32:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-02 21:36:57 +0100
commit3a97b1edecd630c0f48d3b0a28f053b0489a9597 (patch)
tree4743b6dcef79e840defe3f0c9f326801845aadf4 /kde-plasma/plasma-nm
parentmedia-radio/flrig: Drop old (diff)
downloadgentoo-3a97b1edecd630c0f48d3b0a28f053b0489a9597.tar.gz
gentoo-3a97b1edecd630c0f48d3b0a28f053b0489a9597.tar.bz2
gentoo-3a97b1edecd630c0f48d3b0a28f053b0489a9597.zip
kde-plasma: Add KDE Plasma 5.11.5
See also: https://www.kde.org/announcements/plasma-5.11.4-5.11.5-changelog.php Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.11.5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 5427d622647c..144cbb26b98f 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.10.5.tar.xz 706724 BLAKE2B baf83a37ba88e8b695b9dd46805c8652e5d7aa8e6033515812971da399baedb29761c6fcf1cff69bcdc7f2505e44d33529d9c4f731e0f955369e4c16cdaed3fc SHA512 f2502368e883b4be3dd416be6e294e87cef259ac8c1b7853b63fba291e19ac43c5175c186ee287fb843409251fc1ef97eac87de7929ef48695fc409a0de8e05b
DIST plasma-nm-5.11.4.tar.xz 695232 BLAKE2B 4656cc59184f0ee119507190e8699c27c732a05889a6d6953627179ece9670a9b161b268b7480d96f228c5d5b23db034d8ab7fed5a9230bd3038043ae396211c SHA512 6ef1ab68434c14137fa1a5919dcccc9abb5086ce6d9f5e0ccbb0903adee450aec41aef90a031f060be61af7eb98fa2bf7d5474079148a51abf2518cd2eaed5a9
+DIST plasma-nm-5.11.5.tar.xz 718500 BLAKE2B bdd9520cfa3a305f7f2c271fdfc9678b43ed46e160ff7c7485a963889b32e60f56408bcc39b4fce81e570ce194410730a628bb2eb96afcfba8704b787d90c05a SHA512 6bc42e9b385fff03d994d66fb2088ce22b2766588c655466e4e26a0b57f1533c142ce7712c9182d9003368f30086333ea9670bac54b9b797e58a968f8bfc3512
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.11.5.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.11.5.ebuild
new file mode 100644
index 000000000000..85c63f9efa3a
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.11.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=' '5.40.0-r1')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5]
+ >=net-misc/networkmanager-0.9.10.0[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep plasma-workspace)
+ !kde-plasma/plasma-nm:4
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-add_EAP-PWD.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package modemmanager ModemManager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}