summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-22 17:07:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-22 17:28:38 +0200
commitb54093930af484cab95f7498f36027e02d557af3 (patch)
treeccf8f779da1c82044f427ce6e7ef191abc6bb997 /kde-plasma/plasma-browser-integration
parentkde-plasma/plasma-activities-stats: 6.2.2 version bump (diff)
downloadgentoo-b54093930af484cab95f7498f36027e02d557af3.tar.gz
gentoo-b54093930af484cab95f7498f36027e02d557af3.tar.bz2
gentoo-b54093930af484cab95f7498f36027e02d557af3.zip
kde-plasma/plasma-browser-integration: 6.2.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-browser-integration')
-rw-r--r--kde-plasma/plasma-browser-integration/Manifest1
-rw-r--r--kde-plasma/plasma-browser-integration/plasma-browser-integration-6.2.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/plasma-browser-integration/Manifest b/kde-plasma/plasma-browser-integration/Manifest
index 5537cc039dc1..2e7892d741c3 100644
--- a/kde-plasma/plasma-browser-integration/Manifest
+++ b/kde-plasma/plasma-browser-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-browser-integration-6.1.5.tar.xz 222644 BLAKE2B d36dde47476446bae361fef0553eacae75e09709250246d3325f365e0f64b10f5c04502faf19e96714e838abc5ae95b925f14e603919170cf331cde925e91826 SHA512 2f16dbe197e0b9dd0c2e5433680d4422f8e763059a0cbb662187bcb50c446fb12add37b0edc8619a20b1abffe2f76d2b9a87bcf6b5ce030e2ba25efaddb1def9
DIST plasma-browser-integration-6.2.1.tar.xz 223080 BLAKE2B 9d5fe826efe7a8dc69149a5847695119b6a303ca7fd04ba613750ace6f430e3f910a7d5d04ed4aaca851a182d0234802a3d4b17371d084df36690443519ca8f6 SHA512 8c3284c8ea7cd0def6acf0387337ba99dadc904d7d8b11e430eae655d8feaab3cb37630e9fa3846ab8f16e9377a12ecdfce25acb62581b5c614e061ae7742fa9
+DIST plasma-browser-integration-6.2.2.tar.xz 223112 BLAKE2B 8af6d7a0fec95097202671ee14b0b0a9ea2f9c3074262b86966c82c7ade197a4d337369abef2d6500e82f733b90d7db47343f0999c8c499224d59687c60d793c SHA512 ca50e920e085295f5b31d4ca02626508cf649089f5523bef8067d6d863192c70c9bcaa2a32ad8cf2fdf73ba15f8b903930dac00d48907759f15d56bdec09a41b
diff --git a/kde-plasma/plasma-browser-integration/plasma-browser-integration-6.2.2.ebuild b/kde-plasma/plasma-browser-integration/plasma-browser-integration-6.2.2.ebuild
new file mode 100644
index 000000000000..81814cfcdce7
--- /dev/null
+++ b/kde-plasma/plasma-browser-integration/plasma-browser-integration-6.2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.7.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Integrate Chrome/Firefox better into Plasma through browser extensions"
+HOMEPAGE+=" https://community.kde.org/Plasma/Browser_Integration"
+
+LICENSE="GPL-3+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kfilemetadata-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/purpose-${KFMIN}:6
+ >=kde-plasma/plasma-activities-${PVCUT}:6
+ >=kde-plasma/plasma-workspace-${PVCUT}:6
+"
+DEPEND="${RDEPEND}
+ >=kde-frameworks/krunner-${KFMIN}:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMOZILLA_DIR="${EPREFIX}/usr/$(get_libdir)/mozilla"
+ )
+
+ ecm_src_configure
+}