summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-16 16:27:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-16 18:29:28 +0200
commitdd40deccd8b408b61c8e115d102488c112040fa8 (patch)
tree0a96488a3c5a47afccd1c0c13b494e1b5bcf02e5 /kde-plasma/kwallet-pam
parentmedia-gfx/digikam: Drop obsolete 7.0.0_beta3-qt-5.15.patch (diff)
downloadgentoo-dd40deccd8b408b61c8e115d102488c112040fa8.tar.gz
gentoo-dd40deccd8b408b61c8e115d102488c112040fa8.tar.bz2
gentoo-dd40deccd8b408b61c8e115d102488c112040fa8.zip
kde-plasma: Add KDE Plasma 5.19.1
Closes: https://bugs.gentoo.org/727760 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.19.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 9401c28e9f81..4b1dc3bd0e35 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.18.5.tar.xz 19800 BLAKE2B 695fb89d1a54bfc44b06bee4881ae357a42c82b6506a6ed7966c30bb28137ee379ac1beb9391982c15ac63e95c0a1bbba2e0950ee89e050a2ceaf296b98958d4 SHA512 050b3ca66f3b078bb7bccb4a3b7750787bf22d18af60972969f83141b99eac4441fa08d48022278cfe28c8f96f7a1d9ca346f155d8ddbdb60b17bc9c142521cc
DIST kwallet-pam-5.19.0.tar.xz 19844 BLAKE2B eac2b22febe8eef49ddb7f17707bfb6d2e5bc9dff5fd7b458d4e1cb9cdadf93046705d11b2bfcb8a3dc34d8a4cf874cd1bfa99b5b042d2bc632ae55f130dc960 SHA512 0191fdfad14853d1ead9bd18786ea5885814129cfc0b49bec556b3ce8b75a6cf1d47cec4c683ff2477cfbfb9ce5ebc263455fda05181d69b88988a5dc9e84d0b
+DIST kwallet-pam-5.19.1.tar.xz 19860 BLAKE2B 68c15de0b2b41722f1ef25a449223a84385483667914d53f15241cd001d45896a7c31be491dc733adb8036e6af1bc6c103e0cf026a94fa87c1d4b46f2e0740ed SHA512 c078c81b48f4f5e5c8de269184233d720bca215ee875d05c29d4b2bc45a4c90b0ba8a679d6380eb5a48748fcc49482020dad151799d999aafb72e8dae3b877fd
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.19.1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.19.1.ebuild
new file mode 100644
index 000000000000..7f2939b271af
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.19.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.70.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ dev-libs/libgcrypt:0=
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}