summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-12 15:21:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-12 17:31:02 +0100
commit67611cf2cca23eeaab9913c7ad556fe3c579b61f (patch)
treee743cacedda21faf6b65773d30dca2381404905b /kde-plasma/kinfocenter
parentkde-plasma/kglobalacceld: 6.0.2 version bump (diff)
downloadgentoo-67611cf2cca23eeaab9913c7ad556fe3c579b61f.tar.gz
gentoo-67611cf2cca23eeaab9913c7ad556fe3c579b61f.tar.bz2
gentoo-67611cf2cca23eeaab9913c7ad556fe3c579b61f.zip
kde-plasma/kinfocenter: 6.0.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-6.0.2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 531c2e3eb56a..8aa87e148353 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -2,3 +2,4 @@ DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26
DIST kinfocenter-5.27.10.tar.xz 1016624 BLAKE2B ac6981ee8e4e04ae11e66f03d52f1e05e3354adc7cefd7757cfb529ae4fa59f041713e9435e038ee4ebb2a3c64cca738907cc4dac3456719290e938483fa93f6 SHA512 4ad5e30d1ed030ba1b6935c30e1309ed41f3e9e438a219515e3c926c9dfcfc0041f2ded8ce4f835c631ed866ee10b5bb82493c23e35c6d41cd1a3d1729c03cd8
DIST kinfocenter-5.27.11.tar.xz 1018276 BLAKE2B 921832d3c52abfe35d3b77f34161c630d54c6fe8675eac6b2dcc343ab21b7c30b501216c9762aa90a8f5bfc036d2d8859a7419478ec38a85afcbf90315788cc1 SHA512 24a9df9fb28637e39293669569e4be896956ecfc3a27719821a1498f541aed220e7ebcd0e1a0b63051562690a9400b7fefc9c1217763c87009745e886573205e
DIST kinfocenter-6.0.1.tar.xz 833152 BLAKE2B 4ce3092723626d2f03e187452975539f3c85cfa44e4786e7f40adfd8de5ddcd21af878a740a92465ebbb6bae176513b5542c9487e5cbbb24def2f70a84d0c093 SHA512 705f708dd21495931a2dcabbc0aacdeaa95323d99400a9e1b75d57f1f3b68a3cfba800666a4499fa0b87cbc81361b149e8d87e319d7ead4cd702259427520cc8
+DIST kinfocenter-6.0.2.tar.xz 833220 BLAKE2B e63786f6d6117a31566c4991e8ae610d9b70043ca1def7575b8f07232e5a9322af555beeec88ab8243126ff25eb13b10722a2b046727b3d1c157fe60cf5a38a1 SHA512 d013aa3f188e8820823df5662e8cf639ffff668942c59890550950355ca3af8b7efc2da902d1df20f542a94bd03acc831cda91e9f8df86c00ebfd75cccfb4b55
diff --git a/kde-plasma/kinfocenter/kinfocenter-6.0.2.ebuild b/kde-plasma/kinfocenter/kinfocenter-6.0.2.ebuild
new file mode 100644
index 000000000000..6514f41e79f6
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-6.0.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gles2-only=,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ || (
+ >=dev-qt/qttools-${QTMIN}:6[qdbus]
+ dev-qt/qdbus:*
+ )
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-plasma/kde-cli-tools-${PVCUT}:*
+ >=kde-plasma/systemsettings-${PVCUT}:6
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ -DCMAKE_DISABLE_FIND_PACKAGE_SeleniumWebDriverATSPI=ON # missing
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}