summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-06 23:17:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-07 10:05:56 +0100
commit1897dad7b7040f29e632e7bfe1a4513f674de077 (patch)
treed2fa840046c446f84b79b9d7777eea73dc9bb974 /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.27.10 version bump (diff)
downloadgentoo-1897dad7b7040f29e632e7bfe1a4513f674de077.tar.gz
gentoo-1897dad7b7040f29e632e7bfe1a4513f674de077.tar.bz2
gentoo-1897dad7b7040f29e632e7bfe1a4513f674de077.zip
kde-plasma/kinfocenter: 5.27.10 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.27.10.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 01d9b32a914f..02edb6f3ea6e 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,2 +1,3 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
+DIST kinfocenter-5.27.10.tar.xz 1016624 BLAKE2B ac6981ee8e4e04ae11e66f03d52f1e05e3354adc7cefd7757cfb529ae4fa59f041713e9435e038ee4ebb2a3c64cca738907cc4dac3456719290e938483fa93f6 SHA512 4ad5e30d1ed030ba1b6935c30e1309ed41f3e9e438a219515e3c926c9dfcfc0041f2ded8ce4f835c631ed866ee10b5bb82493c23e35c6d41cd1a3d1729c03cd8
DIST kinfocenter-5.27.9.tar.xz 1016368 BLAKE2B 14281837c83947ef1f75b686efdcbb34243c4cab21d5de2198fdc87252b3fb0d20a3052ebf772e12b53960d7e9cd9cbf7c18abe8d943d3ede058b518f5884047 SHA512 9ba52890b4924989e68a7cdff2841ebd2adceac6b7412fecaaae31b98ba997ab7bf9a6e7917412b19e9787329bc16a1973bbff546816ffe3f2037e4840de7c19
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.27.10.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.27.10.ebuild
new file mode 100644
index 000000000000..e2c7a80b0aed
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.27.10.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.106.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.9
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qdbus:*
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:*
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}