summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 11:50:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 13:31:40 +0200
commit78d3baee6a4c834139f8030a632e31db75cab0c6 (patch)
tree97353bfd1f6a7a440e3975e56e8b4ed8e8a01c26 /kde-frameworks/kwindowsystem
parentapp-text/libmspub: Fix build with GCC 10, EAPI-7 bump (diff)
downloadgentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.tar.gz
gentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.tar.bz2
gentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.zip
kde-frameworks: Add KDE Frameworks 5.70.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwindowsystem')
-rw-r--r--kde-frameworks/kwindowsystem/Manifest1
-rw-r--r--kde-frameworks/kwindowsystem/kwindowsystem-5.70.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/kwindowsystem/Manifest b/kde-frameworks/kwindowsystem/Manifest
index 4a2a0d90e75d..9463c152c66d 100644
--- a/kde-frameworks/kwindowsystem/Manifest
+++ b/kde-frameworks/kwindowsystem/Manifest
@@ -1,2 +1,3 @@
DIST kwindowsystem-5.67.0.tar.xz 175396 BLAKE2B 9e8ebb93d01e16bcda6f5aa1a8e28bc2949bfec72da18f67f3e7f5cb36eb1143410f7603d3adae9b6b1bb6c90017d51fb20af2d0cb94a1c27e73c44460cbccf9 SHA512 09aab6459c9b90effa8a2524c7415966992fdab986dd2313b3b8a72084f0e511da8b2c490ccc12836cc4c8555fe4c32f8c94d37b39db1d5736af7dd2f6b661bc
DIST kwindowsystem-5.69.0.tar.xz 179376 BLAKE2B ef87eec356eb4b92195687091b6a796f3b1aa9876a2593566070f113a082686538bf61f1aa83893d8062a0fc9b058b9b5a52806fbf33324c21eaff0d14e70848 SHA512 ec6cd2a05f03c040385efbf7b076971f91bc67c26c399dafec88b651bef9c802e2623c8046b442f8d90803fa9c89d3258708fb71f3746b97f1e0507c84b1f6e4
+DIST kwindowsystem-5.70.0.tar.xz 179304 BLAKE2B 379130c9f9a20fd7ba7bac472d6c77d57b3d1f0d11658c3dc893e4e9c8f061c12ce714189844cb9d93b23b3e0f5f5b906a753899665697e839241b87727c6e1f SHA512 1ada61fdef5e43c218f1904b6700d65bb729536ef3586b369f76ebe87e3ab418214a440435a3286a590d0df03bd064ce957bffaddf03a3bc972aa43bfbb417d0
diff --git a/kde-frameworks/kwindowsystem/kwindowsystem-5.70.0.ebuild b/kde-frameworks/kwindowsystem/kwindowsystem-5.70.0.ebuild
new file mode 100644
index 000000000000..0ce9461c442c
--- /dev/null
+++ b/kde-frameworks/kwindowsystem/kwindowsystem-5.70.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework providing access to properties and features of the window manager"
+LICENSE="|| ( LGPL-2.1 LGPL-3 ) MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls X"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+DOCS=( docs/README.kstartupinfo )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}